summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-08-19 16:06:00 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-08-19 16:12:35 +0200
commita1d5372f3d73b3ef7061cfc567ef59c3a6fd4886 (patch)
treefde78a3d73dc2b3fd9d0fd9c0b3e73032caad908 /net-libs/gsoap
parentwww-apache/mod_gnutls: requires net-libs/gnutls[pkcs11] at runtime (diff)
downloadgentoo-a1d5372f3d73b3ef7061cfc567ef59c3a6fd4886.tar.gz
gentoo-a1d5372f3d73b3ef7061cfc567ef59c3a6fd4886.tar.bz2
gentoo-a1d5372f3d73b3ef7061cfc567ef59c3a6fd4886.zip
net-libs/gsoap: bump to v2.8.105
Closes: https://bugs.gentoo.org/707526 Package-Manager: Portage-3.0.3, Repoman-3.0.0 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-libs/gsoap')
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.105.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index 8d59309406b2..b9d3b49ec73f 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -1,3 +1,4 @@
+DIST gsoap_2.8.105.zip 32728935 BLAKE2B 2a72080566811e65dd3fbb45af40f308ab2950edd6b142359019fdb1b3f84bd4cb13d5e5a8d8ee4ca35fb685535752bed225982fa7861be9e7872be93ab9c155 SHA512 3b7b66ef738e9ba78f0c9d5ec141faab102dc2ed7c528e84358d530ec8cb913c559438bb86ae0f22e0736c4cd9be9e74f364a44257189ccaa1e6d001317f99de
DIST gsoap_2.8.84.zip 32538551 BLAKE2B cab2b75ac931ee6063af47975665f45514cb94f5514fb1f76d17ccb2e71d64d4ebd43543cc004ff7f5c49982975ebaa38e555e3bc45dbc370aae991bc7639273 SHA512 ec050119cd3e480b266cad36823f4862fe0ac21045ce901c3c91a552eae2fbf9e1cd515458835807cce54c04df7835a980a299d37f418190cd57684fd6bdcf79
DIST gsoap_2.8.87.zip 32545316 BLAKE2B c2d0f9fafdfa9de83ea35f8dfc88e23d9d80967a2e58c30d554d539fd93056d7a8eb00ea9c928c6cf786e4888eb9f942ba4574e343de0c0104fce8b270494d6a SHA512 638bf9b2b8aca5facba518f136ad5af5bda41f2b92ee345ee6989d73223a571ce5ddab23c0b65259e9fd524039250d861defc8cfc2fc0a366a578ce3629b9ca4
DIST gsoap_2.8.91.zip 32553307 BLAKE2B 463c2d9c2d56c2a09fa8c9ebea7fa8059ed050cff81780b04a1a47ee1f016e385e6eb338ca740a40cd0c9483b4e10cf0963d02c52d6020863ce015e2f9cf2024 SHA512 ed99f1a20fd95edc7f24cf55454ee057b8c88d2e5b5b153b61c44c57bf4d92fb65ed557e9cb9ea89e3fa8939689c0e30791cebdb91b837482ec8ec13ae281abc
diff --git a/net-libs/gsoap/gsoap-2.8.105.ebuild b/net-libs/gsoap/gsoap-2.8.105.ebuild
new file mode 100644
index 000000000000..b269cd88b436
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.105.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="|| ( gSOAP GPL-2+-with-openssl-exception ) GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+PATCHES=(
+ # Fix Pre-ISO headers
+ "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # enable shared libs https://bugs.gentoo.org/583398
+ "${FILESDIR}/${PN}-2.8.91-shared_libs.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ # Don't include xlocale.h as it got removed in >=glibc-2.26
+ --disable-xlocale
+ $(use_enable debug)
+ $(use_enable examples samples)
+ $(usex gnutls --enable-gnutls '')
+ $(usex ipv6 --enable-ipv6 '')
+ $(usex ssl '' --disable-ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ docinto html
+ dodoc changelog.md
+
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ if use examples; then
+ rm -r gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ docinto html
+ dodoc -r gsoap/doc/*
+ fi
+}