summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-19 23:08:46 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2016-10-20 00:02:14 +0200
commitc447334b7b8f24fa766bd51a1159e9b9a25b337d (patch)
tree666f4a2f8b43af8845ff2f8ea5ce07d1568f84e5 /net-libs/gtk-vnc
parentdev-python/progressbar: clean up old. (diff)
downloadgentoo-c447334b7b8f24fa766bd51a1159e9b9a25b337d.tar.gz
gentoo-c447334b7b8f24fa766bd51a1159e9b9a25b337d.tar.bz2
gentoo-c447334b7b8f24fa766bd51a1159e9b9a25b337d.zip
net-libs/gtk-vnc: suffix all inner functions to avoid collisions with tools in PATH
Gentoo-bug: 597196 Package-Manager: portage-2.3.1
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.6.0.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.6.0.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.6.0.ebuild
index 7e1f0079c25b..242b35d595f3 100644
--- a/net-libs/gtk-vnc/gtk-vnc-0.6.0.ebuild
+++ b/net-libs/gtk-vnc/gtk-vnc-0.6.0.ebuild
@@ -98,7 +98,7 @@ src_configure() {
--with-python
}
- configure() {
+ configure_normal() {
ECONF_SOURCE="${S}" gnome2_src_configure \
${myconf[@]} \
--with-gtk=${MULTIBUILD_VARIANT} \
@@ -113,7 +113,7 @@ src_configure() {
local MULTIBUILD_VARIANTS
compute_variants
- multibuild_foreach_variant run_in_build_dir configure
+ multibuild_foreach_variant run_in_build_dir configure_normal
}
src_compile() {
@@ -127,7 +127,7 @@ src_compile() {
gtkvnc_la_DEPENDENCIES="${GTK2_BUILDDIR}/src/libgtk-vnc-1.0.la"
}
- compile() {
+ compile_normal() {
gnome2_src_compile
if [[ ${MULTIBUILD_ID} == 2.0 ]] && use python ; then
@@ -138,7 +138,7 @@ src_compile() {
local MULTIBUILD_VARIANTS
compute_variants
- multibuild_foreach_variant run_in_build_dir compile
+ multibuild_foreach_variant run_in_build_dir compile_normal
}
src_test() {
@@ -158,7 +158,7 @@ src_install() {
gtkvnc_la_DEPENDENCIES="${GTK2_BUILDDIR}/src/libgtk-vnc-1.0.la"
}
- install() {
+ install_normal() {
gnome2_src_install
if [[ ${MULTIBUILD_ID} == 2.0 ]] && use python ; then
@@ -169,5 +169,5 @@ src_install() {
local MULTIBUILD_VARIANTS
compute_variants
- multibuild_foreach_variant run_in_build_dir install
+ multibuild_foreach_variant run_in_build_dir install_normal
}