summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/gupnp-igd/gupnp-igd-0.2.2-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/gupnp-igd/gupnp-igd-0.2.2-r1.ebuild')
-rw-r--r--net-libs/gupnp-igd/gupnp-igd-0.2.2-r1.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/net-libs/gupnp-igd/gupnp-igd-0.2.2-r1.ebuild b/net-libs/gupnp-igd/gupnp-igd-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..f26439b12497
--- /dev/null
+++ b/net-libs/gupnp-igd/gupnp-igd-0.2.2-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils gnome.org python-r1
+
+DESCRIPTION="Library to handle UPnP IGD port mapping for GUPnP"
+HOMEPAGE="http://gupnp.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
+IUSE="+introspection python"
+
+RDEPEND="
+ net-libs/gssdp
+ >=net-libs/gupnp-0.18
+ >=dev-libs/glib-2.16:2
+ introspection? ( >=dev-libs/gobject-introspection-0.10 )
+ python? (
+ >=dev-libs/gobject-introspection-0.10
+ >=dev-python/pygobject-2.16:2[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+# The only existing test is broken
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-underlinking.patch
+ "${FILESDIR}"/${PN}-0.1.11-disable_static_modules.patch
+ )
+
+src_prepare() {
+ rm missing || die
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+
+ # Python bindings are built/installed manually.
+ if use python; then
+ sed -e "/PYTHON_SUBDIR =/s/ python//" -i Makefile.am Makefile.in || die
+ fi
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ --disable-gtk-doc
+ $(use_enable introspection)
+ $(use_enable python)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use python; then
+ python_copy_sources
+
+ building() {
+ cd "${BUILD_DIR}"/python || die
+ emake \
+ PYTHON_INCLUDES="-I$(python_get_includedir)" \
+ pyexecdir="$(python_get_sitedir)"
+ }
+ python_foreach_impl building
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use python; then
+ installation() {
+ cd "${BUILD_DIR}"/python || die
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ install
+ }
+ python_foreach_impl installation
+ fi
+}