summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/iax/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/iax/files')
-rw-r--r--net-libs/iax/files/0.2.2-debug.patch21
-rw-r--r--net-libs/iax/files/0.2.2-memset.patch12
-rw-r--r--net-libs/iax/files/0.2.2-sandbox.patch19
3 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/iax/files/0.2.2-debug.patch b/net-libs/iax/files/0.2.2-debug.patch
new file mode 100644
index 000000000000..68efdfdd237a
--- /dev/null
+++ b/net-libs/iax/files/0.2.2-debug.patch
@@ -0,0 +1,21 @@
+diff -uNr iax-0.2.2.ORIG/configure.in iax-0.2.2/configure.in
+--- iax-0.2.2.ORIG/configure.in 2014-05-13 13:23:35.083867921 +0100
++++ iax-0.2.2/configure.in 2014-05-13 13:24:25.879870451 +0100
+@@ -25,6 +25,8 @@
+ fi
+
+ if test "$enable_extreme_debug" = yes ; then
++ AC_DEFINE(DEBUG_SUPPORT)
++ AC_DEFINE(DEBUG_DEFAULT)
+ AC_DEFINE(EXTREME_DEBUG)
+ fi
+
+diff -uNr iax-0.2.2.ORIG/src/Makefile.am iax-0.2.2/src/Makefile.am
+--- iax-0.2.2.ORIG/src/Makefile.am 2014-05-13 13:23:35.082867921 +0100
++++ iax-0.2.2/src/Makefile.am 2014-05-13 13:24:32.439870777 +0100
+@@ -1,5 +1,4 @@
+ CFLAGS += -g -Wall -Wstrict-prototypes -I .
+-CFLAGS += -DDEBUG_SUPPORT -DDEBUG_DEFAULT
+ CFLAGS += $(UCFLAGS)
+
+
diff --git a/net-libs/iax/files/0.2.2-memset.patch b/net-libs/iax/files/0.2.2-memset.patch
new file mode 100644
index 000000000000..08408eef98f7
--- /dev/null
+++ b/net-libs/iax/files/0.2.2-memset.patch
@@ -0,0 +1,12 @@
+diff -uNr iax-0.2.2.ORIG/src/md5.c iax-0.2.2/src/md5.c
+--- iax-0.2.2.ORIG/src/md5.c 2014-05-13 13:26:51.570877706 +0100
++++ iax-0.2.2/src/md5.c 2014-05-13 13:27:08.567878553 +0100
+@@ -165,7 +165,7 @@
+ MD5Transform(ctx->buf, (uint32 *) ctx->in);
+ byteReverse((unsigned char *) ctx->buf, 4);
+ memcpy(digest, ctx->buf, 16);
+- memset(ctx, 0, sizeof(ctx)); /* In case it's sensitive */
++ memset(ctx, 0, sizeof(*ctx)); /* In case it's sensitive */
+ }
+
+ #ifndef ASM_MD5
diff --git a/net-libs/iax/files/0.2.2-sandbox.patch b/net-libs/iax/files/0.2.2-sandbox.patch
new file mode 100644
index 000000000000..2dc141a73b18
--- /dev/null
+++ b/net-libs/iax/files/0.2.2-sandbox.patch
@@ -0,0 +1,19 @@
+diff -uNr iax-0.2.2.ORIG/src/Makefile.am iax-0.2.2/src/Makefile.am
+--- iax-0.2.2.ORIG/src/Makefile.am 2014-05-13 12:45:58.343755528 +0100
++++ iax-0.2.2/src/Makefile.am 2014-05-13 12:46:30.044757107 +0100
+@@ -9,10 +9,9 @@
+ EXTRA_DIST = md5.h frame.h iax-client.h iax.h
+
+ install:
+- mkdir -p $(includedir)/iax
+- install -m 644 md5.h $(includedir)/iax
+- install -m 644 frame.h $(includedir)/iax
+- install -m 644 iax.h $(includedir)/iax
+- install -m 644 iax-client.h $(includedir)/iax
+- /sbin/ldconfig
++ mkdir -p $(DESTDIR)$(includedir)/iax
++ install -m 644 md5.h $(DESTDIR)$(includedir)/iax
++ install -m 644 frame.h $(DESTDIR)$(includedir)/iax
++ install -m 644 iax.h $(DESTDIR)$(includedir)/iax
++ install -m 644 iax-client.h $(DESTDIR)$(includedir)/iax
+