summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-09-09 23:01:07 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-09-09 23:08:35 +1000
commitcf24b5b97b76b5dcfe778064017910995466796b (patch)
tree0dab77bc729bd31a91fd990a8d335d41abd48260 /net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild
parentnet-im/qutim: Fix manifest (diff)
downloadgentoo-cf24b5b97b76b5dcfe778064017910995466796b.tar.gz
gentoo-cf24b5b97b76b5dcfe778064017910995466796b.tar.bz2
gentoo-cf24b5b97b76b5dcfe778064017910995466796b.zip
net-libs/libaccounts-glib: version bump 1.23
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild')
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild
new file mode 100644
index 000000000000..928af3370a31
--- /dev/null
+++ b/net-libs/libaccounts-glib/libaccounts-glib-1.23.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools eutils vcs-snapshot xdg-utils
+
+DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/libaccounts-glib/repository/archive.tar.gz?ref=VERSION_${PV} -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+"
+
+DOCS=( AUTHORS NEWS )
+
+pkg_setup() {
+ xdg_environment_reset
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-python \
+ --disable-tests \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}