summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-01 10:29:13 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-01 11:06:59 +0200
commit3f7eab9ae999cfd31debc0a9ebe822ed0fb375e7 (patch)
tree5492a6fd7cc23f379aa70f65b85de5970eadd179 /net-libs/libbtbb/libbtbb-2018.12.1.ebuild
parentsys-cluster/rdma-core: Version bump (v31.0) (diff)
downloadgentoo-3f7eab9ae999cfd31debc0a9ebe822ed0fb375e7.tar.gz
gentoo-3f7eab9ae999cfd31debc0a9ebe822ed0fb375e7.tar.bz2
gentoo-3f7eab9ae999cfd31debc0a9ebe822ed0fb375e7.zip
net-libs/libbtbb: Remove USE=extras (python2)
Closes: https://bugs.gentoo.org/735418 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/libbtbb/libbtbb-2018.12.1.ebuild')
-rw-r--r--net-libs/libbtbb/libbtbb-2018.12.1.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/net-libs/libbtbb/libbtbb-2018.12.1.ebuild b/net-libs/libbtbb/libbtbb-2018.12.1.ebuild
index b2017354f2a1..d3976d1260b1 100644
--- a/net-libs/libbtbb/libbtbb-2018.12.1.ebuild
+++ b/net-libs/libbtbb/libbtbb-2018.12.1.ebuild
@@ -3,10 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 )
-DISTUTILS_OPTIONAL=1
-
-inherit multilib cmake-utils python-single-r1
+inherit multilib cmake-utils
DESCRIPTION="A library to decode Bluetooth baseband packets"
HOMEPAGE="http://libbtbb.sourceforge.net/"
@@ -24,9 +21,9 @@ fi
LICENSE="GPL-2"
SLOT="0/${PV}"
-IUSE="extras static-libs wireshark-plugins"
+IUSE="static-libs wireshark-plugins"
-RDEPEND="extras? ( ${PYTHON_DEPS} )
+RDEPEND="
wireshark-plugins? (
>=net-analyzer/wireshark-1.8.3-r1:=
)
@@ -35,8 +32,6 @@ DEPEND="${RDEPEND}
wireshark-plugins? ( dev-libs/glib
virtual/pkgconfig )"
-REQUIRED_USE="extras? ( ${PYTHON_REQUIRED_USE} )"
-
get_PV() { local pv=$(best_version $1); pv=${pv#$1-}; pv=${pv%-r*}; pv=${pv//_}; echo ${pv}; }
which_plugins() {
@@ -74,7 +69,7 @@ src_configure() {
CMAKE_USE_DIR="${S}"
BUILD_DIR="${S}"_build
local mycmakeargs=(
- -DENABLE_PYTHON=$(usex extras)
+ -DENABLE_PYTHON=OFF
-DBUILD_STATIC_LIB=$(usex static-libs)
-DBUILD_ROOT="${ED}"
)