summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libcapi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libcapi')
-rw-r--r--net-libs/libcapi/Manifest1
-rw-r--r--net-libs/libcapi/files/libcapi-3.0.7-remove-libcapi20dyn.patch21
-rw-r--r--net-libs/libcapi/libcapi-3.0.7-r1.ebuild24
-rw-r--r--net-libs/libcapi/metadata.xml5
4 files changed, 51 insertions, 0 deletions
diff --git a/net-libs/libcapi/Manifest b/net-libs/libcapi/Manifest
new file mode 100644
index 000000000000..66216a1ed8ab
--- /dev/null
+++ b/net-libs/libcapi/Manifest
@@ -0,0 +1 @@
+DIST libcapi20-3.0.7.tar.bz2 474174 SHA256 f36c7d1d8a46dd76b1e3443d6f5478ad16177d3f91c9f67bc654608167020293 SHA512 c14e493f34fbd8477aed8efc0e6ee8dc07c6007be75610d59a15ce23f48cd5cd53da1b1ac64c11e7516df5aff40877c76ce7a6d72b5c7b1d24beee7592a51bbe WHIRLPOOL 7ba7530ea680a22d0538af8d14e66b51735c7e125f9450d845794a96c964dcf968daf4a02afd1b2a00e66b9898d5b6d00074aab418363c100815a2301d7ab3b4
diff --git a/net-libs/libcapi/files/libcapi-3.0.7-remove-libcapi20dyn.patch b/net-libs/libcapi/files/libcapi-3.0.7-remove-libcapi20dyn.patch
new file mode 100644
index 000000000000..1e8d9a88afac
--- /dev/null
+++ b/net-libs/libcapi/files/libcapi-3.0.7-remove-libcapi20dyn.patch
@@ -0,0 +1,21 @@
+diff --git a/Makefile.am b/Makefile.am
+index 46f308c..df8ea69 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -7,7 +7,6 @@ MAINTAINERCLEANFILES = configure aclocal.m4 Makefile.in config.h.in
+ stamp-h.in
+ include_HEADERS = capi20.h capiutils.h capicmd.h capi_mod.h capi_debug.h
+ lib_LTLIBRARIES = libcapi20.la
+-lib_LIBRARIES = libcapi20dyn.a
+
+ libcapi20_la_SOURCES = capi20.c capifunc.c convert.c capi_defs.h compat/byteswap.h
+ libcapi20_la_LDFLAGS = -version-info ${LIBCAPI_VERSION}:${LIBCAPI_VERSION_RELEASE}:${LIBCAPI_VERSION_AGE} -lc -rdynamic
+@@ -35,8 +34,6 @@ lib_capi_mod_rcapi_la_CFLAGS = -fno-strict-aliasing
+ lib_capi_mod_rcapi_la_LDFLAGS = -shared -version-info @CAPI_MODULE_LOADER_VERSION@:0:0 -no-undefined
+ lib_capi_mod_rcapi_la_LIBADD = libcapi20.la
+
+-libcapi20dyn_a_SOURCES = capidyn.c
+-libcapi20dyn_a_CFLAGS = -fPIC
+ libcapi20_la_LIBADD = $(LIBADD_DL)
+
+ if WIN32
diff --git a/net-libs/libcapi/libcapi-3.0.7-r1.ebuild b/net-libs/libcapi/libcapi-3.0.7-r1.ebuild
new file mode 100644
index 000000000000..20351c76ae66
--- /dev/null
+++ b/net-libs/libcapi/libcapi-3.0.7-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-multilib
+
+DESCRIPTION="CAPI library used by AVM products"
+HOMEPAGE="http://www.tabos.org/ffgtk"
+SRC_URI="http://www.tabos.org/ffgtk/download/libcapi20-${PV}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/capi20"
+
+RDEPEND="!net-dialup/capi4k-utils"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-remove-libcapi20dyn.patch" )
diff --git a/net-libs/libcapi/metadata.xml b/net-libs/libcapi/metadata.xml
new file mode 100644
index 000000000000..756ddd4a6227
--- /dev/null
+++ b/net-libs/libcapi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+</pkgmetadata>