summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libcrafter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libcrafter')
-rw-r--r--net-libs/libcrafter/Manifest1
-rw-r--r--net-libs/libcrafter/libcrafter-0.3.ebuild38
-rw-r--r--net-libs/libcrafter/libcrafter-9999.ebuild38
-rw-r--r--net-libs/libcrafter/metadata.xml30
4 files changed, 107 insertions, 0 deletions
diff --git a/net-libs/libcrafter/Manifest b/net-libs/libcrafter/Manifest
new file mode 100644
index 000000000000..ec7e1fff2596
--- /dev/null
+++ b/net-libs/libcrafter/Manifest
@@ -0,0 +1 @@
+DIST 0.3.tar.gz 104051 SHA256 4608b10470aaa5a711b13b7c9db93fc6c3daca8c26ae7e81b0d7aa8af3a497aa SHA512 7c396ba942b304dddfaa569adb44697f75568d3ef2ed48dda758e281f3b7c172439309033bbf5498069a4a61a952f93e41af99b129ce874ce76b5ec08da58116 WHIRLPOOL 9444ba34eb9c0f4072bb52d1bc1a0712e274c344af61059f60f626a4465476d65606918bb759e236c97bb8c49733e498f9fa8593862058fb0e0aa397bf489eea
diff --git a/net-libs/libcrafter/libcrafter-0.3.ebuild b/net-libs/libcrafter/libcrafter-0.3.ebuild
new file mode 100644
index 000000000000..ad131de1f696
--- /dev/null
+++ b/net-libs/libcrafter/libcrafter-0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A high level C++ network packet sniffing and crafting library"
+HOMEPAGE="https://github.com/pellegre/libcrafter"
+SRC_URI="https://github.com/pellegre/${PN}/archive/version-${PV}.tar.gz -> ${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ net-libs/libpcap
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+S=${WORKDIR}/${PN}-version-${PV}/${PN}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}
diff --git a/net-libs/libcrafter/libcrafter-9999.ebuild b/net-libs/libcrafter/libcrafter-9999.ebuild
new file mode 100644
index 000000000000..8c799d96fc9a
--- /dev/null
+++ b/net-libs/libcrafter/libcrafter-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils git-r3
+
+DESCRIPTION="a high level library for C++ designed to make easier the creation and decoding of network packets"
+HOMEPAGE="https://code.google.com/p/libcrafter/"
+EGIT_REPO_URI="https://github.com/pellegre/${PN}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+RDEPEND="
+ net-libs/libpcap
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files
+}
diff --git a/net-libs/libcrafter/metadata.xml b/net-libs/libcrafter/metadata.xml
new file mode 100644
index 000000000000..5ecde58044f6
--- /dev/null
+++ b/net-libs/libcrafter/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription lang='en'>
+Libcrafter is a high level library for C++ designed to facilitate the creation
+and decoding of network packets. It is able to craft or decode packets of most
+common networks protocols, send them on the wire, capture them and match
+requests and replies.
+It enables the creation of networking tools in a few lines with a interface
+very similar to <pkg>net-analyzer/scapy</pkg>.
+A packet is described as layers that you stack one upon the other. Fields of
+each layer have useful default values that you can overload.
+
+The library is designed to be used in multithreaded programs where you can
+combine several tasks simultaneously. For example, you can easily design
+something that sniffs, mangles, and sends at the same time you are doing an
+ARP-Spoofing attack.
+It also contains a very naive implementation of the TCP/IP stack (fragmentation
+is no handled yet) at user level that enables working with TCP streams. This
+facilitates the creation of tools for data injection on arbitrary connections,
+IP spoofing and TCP/IP session hijacking.
+
+Supported protocols are:
+
+Ethernet, SLL (Linux cooked-mode capture), ARP, DHCP, DHCP options, IP, IP
+options, IPv6, ICMP, ICMPv6, ICMP extensions, ICMPv6 extensions, TCP, TCP
+options, UDP and DNS
+</longdescription>
+</pkgmetadata>