summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-27 01:23:40 +0000
committerSam James <sam@gentoo.org>2021-02-27 02:24:58 +0000
commit8c48e64ddb2b2a344e7302c255fc12a215d784c9 (patch)
tree69c08c8a402af4bbb18bf75eee16fda55a233d62 /net-libs/libecap
parentnet-libs/libecap: add CHANGELOG to metadata (diff)
downloadgentoo-8c48e64ddb2b2a344e7302c255fc12a215d784c9.tar.gz
gentoo-8c48e64ddb2b2a344e7302c255fc12a215d784c9.tar.bz2
gentoo-8c48e64ddb2b2a344e7302c255fc12a215d784c9.zip
net-libs/libecap: port to EAPI 7
Package-Manager: Portage-3.0.15, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libecap')
-rw-r--r--net-libs/libecap/libecap-1.0.0.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/net-libs/libecap/libecap-1.0.0.ebuild b/net-libs/libecap/libecap-1.0.0.ebuild
index 9b5ee739941d..224da59d982a 100644
--- a/net-libs/libecap/libecap-1.0.0.ebuild
+++ b/net-libs/libecap/libecap-1.0.0.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=7
-inherit autotools-utils eutils toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="API for implementing ICAP content analysis and adaptation"
-HOMEPAGE="http://www.e-cap.org/"
+HOMEPAGE="https://www.e-cap.org/"
SRC_URI="http://www.measurement-factory.com/tmp/ecap/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="1"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE="static-libs"
RDEPEND="!net-libs/libecap:0
!net-libs/libecap:0.2"
@@ -24,4 +23,13 @@ src_prepare() {
# Respect AR. (bug #457734)
tc-export AR
+
+ mv configure.{in,ac} || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # Horrific autotools failure in generated config.h w/o Bash
+ CONFIG_SHELL="${EPREFIX}/bin/bash" econf
}