summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-11-11 13:21:39 +0100
committerPacho Ramos <pacho@gentoo.org>2018-11-11 14:07:26 +0100
commit1f0109e8757ae13596cd31b7fef5ccc1b1d808f5 (patch)
treeecf8e0582ea443958d365d8e506333deb85e6d7f /net-libs/libgssglue/libgssglue-0.4-r1.ebuild
parentgames-board/freedoko: Disable optional gnet support (diff)
downloadgentoo-1f0109e8757ae13596cd31b7fef5ccc1b1d808f5.tar.gz
gentoo-1f0109e8757ae13596cd31b7fef5ccc1b1d808f5.tar.bz2
gentoo-1f0109e8757ae13596cd31b7fef5ccc1b1d808f5.zip
net-libs/libgssglue: Fix no-symlink-lib bug
Closes: https://bugs.gentoo.org/646126 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'net-libs/libgssglue/libgssglue-0.4-r1.ebuild')
-rw-r--r--net-libs/libgssglue/libgssglue-0.4-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/libgssglue/libgssglue-0.4-r1.ebuild b/net-libs/libgssglue/libgssglue-0.4-r1.ebuild
new file mode 100644
index 000000000000..fd4c0748d5d6
--- /dev/null
+++ b/net-libs/libgssglue/libgssglue-0.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Exports a gssapi interface which calls other random gssapi libraries"
+HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
+SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="!app-crypt/libgssapi"
+DEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3-protos.patch
+ "${FILESDIR}"/${PN}-0.4-implicit-declarations.patch
+)
+
+src_prepare() {
+ default
+ sed -i -e "s,/lib/,/$(get_libdir)/," doc/gssapi_mech.conf #646126
+}
+
+src_configure() {
+ # No need to install static libraries, as it uses libdl
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ insinto /etc
+ doins doc/gssapi_mech.conf
+}