summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-17 19:36:59 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-17 19:36:59 +0100
commitdff881f9dfcbf563f3ccb5ae4bc7cb2591887519 (patch)
treebc0e142fa68a3356f15c9c015b93ccdb9a8d9ee2 /net-libs/libhtp
parentnet-im/slack: update QA_PREBUILT (diff)
downloadgentoo-dff881f9dfcbf563f3ccb5ae4bc7cb2591887519.tar.gz
gentoo-dff881f9dfcbf563f3ccb5ae4bc7cb2591887519.tar.bz2
gentoo-dff881f9dfcbf563f3ccb5ae4bc7cb2591887519.zip
net-libs/libhtp: add 0.5.39
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/libhtp')
-rw-r--r--net-libs/libhtp/Manifest1
-rw-r--r--net-libs/libhtp/libhtp-0.5.39.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/libhtp/Manifest b/net-libs/libhtp/Manifest
index afa2a683f1c0..86b9659e76f8 100644
--- a/net-libs/libhtp/Manifest
+++ b/net-libs/libhtp/Manifest
@@ -1 +1,2 @@
DIST libhtp-0.5.38.tar.gz 497753 BLAKE2B 84c4a89914dfadb9e3ab076e6f2354034cd384e7e76c9cbf00a7bf344cfcd7c24de200bd1af7f37356b00fbe13196fd3e49896f301b75fa05ce5b4e4ed297115 SHA512 6f2aa3b564948bde738ff60b917d64ffdcb71bbd5b25f11270ce16400fab6b8aab5c0e2372aff7f6be8818efab4b90843df527604835547691a4585fec9a19fe
+DIST libhtp-0.5.39.tar.gz 499233 BLAKE2B fec9e2b0dd867becde972e9e2bf572a21d90acc747a8ee8338e2fe68240d690706db01b12c3cf8c6bf1b5d4415da4e4a5bf92a056e1dff96f54a9ac569906712 SHA512 2c62b0a9a2f69f999a58acade362e5fcd9d85da5c720a403b0b6e7352981a206781f123aaa2f730803f2ea6088b4491d58b3c2783f8b32e4cfe1517d812e66ff
diff --git a/net-libs/libhtp/libhtp-0.5.39.ebuild b/net-libs/libhtp/libhtp-0.5.39.ebuild
new file mode 100644
index 000000000000..4e39f91bf8c4
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.39.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+IUSE="debug"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # The debug configure logic is broken.
+ ECONF_SOURCE=${S} \
+ econf \
+ $(usex debug '--enable-debug' '') \
+ --disable-static
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
+}