summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 15:15:41 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 15:15:41 +0100
commit9115cb5d71060f561b50e70c1e687989768a1b64 (patch)
tree09c383c36967659d3a9077de8f3e65d5a0a7e332 /net-libs/libisds
parentnet-libs/libisds: Cleanup old versions (diff)
downloadgentoo-9115cb5d71060f561b50e70c1e687989768a1b64.tar.gz
gentoo-9115cb5d71060f561b50e70c1e687989768a1b64.tar.bz2
gentoo-9115cb5d71060f561b50e70c1e687989768a1b64.zip
net-libs/libisds: Sync live ebuild
Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/libisds')
-rw-r--r--net-libs/libisds/libisds-9999.ebuild51
1 files changed, 25 insertions, 26 deletions
diff --git a/net-libs/libisds/libisds-9999.ebuild b/net-libs/libisds/libisds-9999.ebuild
index 29b8477bdd67..eb24a312d360 100644
--- a/net-libs/libisds/libisds-9999.ebuild
+++ b/net-libs/libisds/libisds-9999.ebuild
@@ -1,54 +1,53 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-[[ ${PV} = 9999* ]] && inherit git-r3 autotools
+EAPI=7
+inherit autotools git-r3
DESCRIPTION="Client library for accessing ISDS Soap services"
HOMEPAGE="http://xpisar.wz.cz/libisds/"
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
-else
- SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.xz"
- KEYWORDS="~amd64 ~mips ~x86"
-fi
+EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
LICENSE="LGPL-3"
SLOT="0"
-IUSE="+curl debug nls static-libs test"
+IUSE="+curl debug doc nls openssl test"
RESTRICT="!test? ( test )"
-COMMON_DEPEND="
- app-crypt/gpgme
+RDEPEND="
dev-libs/expat
- dev-libs/libgcrypt:0=
dev-libs/libxml2
curl? ( net-misc/curl[ssl] )
-"
-DEPEND="${COMMON_DEPEND}
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+ openssl? ( dev-libs/openssl:= )
+ !openssl? (
+ app-crypt/gnupg
+ app-crypt/gpgme
+ dev-libs/libgcrypt:=
+ )"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls )"
+BDEPEND="
virtual/pkgconfig
- nls? ( sys-devel/gettext )
-"
-RDEPEND="${COMMON_DEPEND}
- >=app-crypt/gnupg-2
-"
-
-DOCS=( NEWS README AUTHORS ChangeLog )
+ nls? ( sys-devel/gettext )"
src_prepare() {
default
- [[ ${PV} = 9999* ]] && eautoreconf
+ eautoreconf
}
src_configure() {
local myeconfargs=(
--disable-fatalwarnings
+ --disable-static
$(use_with curl libcurl)
$(use_enable curl curlreauthorizationbug)
+ $(use_enable doc)
$(use_enable debug)
$(use_enable nls)
- $(use_enable static-libs static)
+ $(use_enable openssl openssl-backend)
$(use_enable test)
)
econf "${myeconfargs[@]}"
@@ -57,5 +56,5 @@ src_configure() {
src_install() {
default
- find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+ find "${ED}" -name '*.la' -delete || die
}