summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 15:15:39 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 15:15:39 +0100
commitaa7b0c5100d4a8b228b68c9c5a1a8210b96158a6 (patch)
tree159cfd1c6930caa1f5fab4e16a1a28bd75108319 /net-libs/libisds
parentmedia-sound/tap-reverbed: Port to EAPI 7 (diff)
downloadgentoo-aa7b0c5100d4a8b228b68c9c5a1a8210b96158a6.tar.gz
gentoo-aa7b0c5100d4a8b228b68c9c5a1a8210b96158a6.tar.bz2
gentoo-aa7b0c5100d4a8b228b68c9c5a1a8210b96158a6.zip
net-libs/libisds: Bump to 0.11.1
Closes: https://bugs.gentoo.org/710440 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/libisds')
-rw-r--r--net-libs/libisds/Manifest1
-rw-r--r--net-libs/libisds/libisds-0.11.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/net-libs/libisds/Manifest b/net-libs/libisds/Manifest
index 8f3aa379ee10..f22ebfc687eb 100644
--- a/net-libs/libisds/Manifest
+++ b/net-libs/libisds/Manifest
@@ -1,4 +1,5 @@
DIST libisds-0.10.6.tar.xz 724120 BLAKE2B b6d3f42d4ff84c377c9425dfd84a14ae97ccc39ea4bb96169e3a8de21b99dd6e5ceda39a6d4a574ccb418561dbec2507f72afc8b6f185c34ff92202abcc49441 SHA512 602c4e7f047dedff131cda941d02ea41fca7b8ea80eb668ab8f7ab2626a013ddc1a86f1e2c7b5759adf266c7c22c515284e6d4fdd9fd594ad310bed1be6016f4
DIST libisds-0.10.7.tar.xz 724840 BLAKE2B 73d93b518271cbd08787a38da454ceb8fa6c2d421b0291c61cded8f1438d44c5607d1e90d75714c3d76e0886ac723e38dc2a41d60284a58d567abdcba76becd4 SHA512 ba2ef11c2983cb3bc8f779e7af3fb8319d38a786911e68c6b53c25aff339b4630bdf78886825ea3da671e87f689cab376cd9e41398f3f74608af932abe7a0023
DIST libisds-0.10.8.tar.xz 726040 BLAKE2B e3509202cb95e6e2bd0a6e7592c3d1d649ecb47806823265e5e12fa3a79a5daff9d249b2f0642d13aaebf1c64243690d06c9387fcb3a166f4b989c19f337c059 SHA512 648ba30c3156ece329d663d0d6e649319d8d104de97ca1946d94c24205c44189be08cb0c573df1f5a889fba487f2d088ac472c3f922a1920e172dda0c592b41e
+DIST libisds-0.11.1.tar.xz 741992 BLAKE2B e1895450b1148c63a365a569fcdfa0d3cf3f2cdd011da6dbe92ea876aa1a9082470f3c7efc5757766df7e870559dd4ba62b59973e22d47401ef575e0fd412ec1 SHA512 8baf126ebf49c5eae6aa7b8f872ad90882a9a5088c8a33ffb415983eaf1ffc1df489f44ae6ba14a69a94bc4f79f455c7937276885afaa29e61c5c67408f7080a
DIST libisds-0.11.tar.xz 741952 BLAKE2B 553613b7f1d8f5b3af1ecff2734584234f5d461c289c08acaf4353b724102ac87da5e60c2b5ffc2895a6441af2a51e0a381ab9df4494d7543edf356b989df891 SHA512 d30708cc6df92f0da9c4fac9acea3c1f3d97ae5ed1f17967e41c4887fe90f5b7375508df987b4b98cc5653a099a78c7a678f8fcb6897de863ff2f4538413f7dd
diff --git a/net-libs/libisds/libisds-0.11.1.ebuild b/net-libs/libisds/libisds-0.11.1.ebuild
new file mode 100644
index 000000000000..d9a4859a617a
--- /dev/null
+++ b/net-libs/libisds/libisds-0.11.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Client library for accessing ISDS Soap services"
+HOMEPAGE="http://xpisar.wz.cz/libisds/"
+SRC_URI="http://xpisar.wz.cz/${PN}/dist/${P}.tar.xz"
+KEYWORDS="~amd64 ~mips ~x86"
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE="+curl debug doc nls openssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/libxml2
+ curl? ( net-misc/curl[ssl] )
+ doc? (
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ )
+ openssl? ( dev-libs/openssl:= )
+ !openssl? (
+ app-crypt/gnupg
+ app-crypt/gpgme
+ dev-libs/libgcrypt:=
+ )"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls )"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-fatalwarnings
+ --disable-static
+ $(use_with curl libcurl)
+ $(use_enable curl curlreauthorizationbug)
+ $(use_enable doc)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable openssl openssl-backend)
+ $(use_enable test)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}