summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-08-07 15:04:40 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-08-07 15:44:16 +0200
commit1b8aed1847c90bb5d40d91c0c0b10592c63ae338 (patch)
tree4660152efd61d427280f9cd3f82e2bdfbd625922 /net-libs/liblockfile
parentmedia-fonts/terminus-font: Bump to version 4.48 (diff)
downloadgentoo-1b8aed1847c90bb5d40d91c0c0b10592c63ae338.tar.gz
gentoo-1b8aed1847c90bb5d40d91c0c0b10592c63ae338.tar.bz2
gentoo-1b8aed1847c90bb5d40d91c0c0b10592c63ae338.zip
net-libs/liblockfile: Bump to version 1.15
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs/liblockfile')
-rw-r--r--net-libs/liblockfile/Manifest1
-rw-r--r--net-libs/liblockfile/liblockfile-1.15.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-libs/liblockfile/Manifest b/net-libs/liblockfile/Manifest
index 0fd9eed430dd..0e46f5408047 100644
--- a/net-libs/liblockfile/Manifest
+++ b/net-libs/liblockfile/Manifest
@@ -1,3 +1,4 @@
DIST liblockfile_1.09.orig.tar.gz 32178 BLAKE2B b78f632e3bf1ed926596abf9fb0450cc325f888ba245d724f6c02800d939f2d5933b0f90bac92d543cdc5ee6b27f8c4fb70901742e83e8d5becbdbc60e20e5b3 SHA512 8577f8bfa9c78983d6a409bc449be0d981e599a6a5f2fc8b43f76a238810ec5e3c180e27280719398f31041ed837fe8ba61df208ce77db77a354453e4579848a
DIST liblockfile_1.13.orig.tar.gz 67720 BLAKE2B c42248c652fda4604a0b4210f77046c2bbb50fc63459da03e1302d436abc21f34e77d17ca9f1e0f80abf674ac9942656014b2ea74bbf9ee92ab17d3c0b2e08cc SHA512 509b00e6841ecdbd6bef0fdf620a31f49b2e07d29c7dd2407297a3e92ded568933d75390f7cab43dd514949c6ccf8924e621324a8d4bbde4c71847b7b257318a
DIST liblockfile_1.14.orig.tar.gz 67856 BLAKE2B 1b83c79217c533ed3f5ef0e3ee33877d541670e14eaa2003b37b5a9b0ae544611f88beb28ecb527d82295e41744e1dfc653b7822436a314c25444a686f30b89d SHA512 d6d75a1ddb55bae8ee63bd0cbacf7ab8cd6d28b29a7d3c2e4a5c31c76c6743ed517cdebd42e3ef5c44698faebfd1537b023510c692b54a1275e7114605fe6550
+DIST liblockfile_1.15.orig.tar.gz 68238 BLAKE2B 3819e6f391467073836ed790ce9b8bbac8e9887d0aea19b1bb083c1020a2e18d3364a087a8c0e962aac66a904768dd843be28e6364b8b150049b6348cfaa944a SHA512 048bbe2c87e85e6ec9b0347809c07183e4210cd565b38653dd1d967106209ccef4146db97afe5a5b7a6d3c58579d4d17f7e241e87be085791bad65b9eeed23f0
diff --git a/net-libs/liblockfile/liblockfile-1.15.ebuild b/net-libs/liblockfile/liblockfile-1.15.ebuild
new file mode 100644
index 000000000000..bcfa527efdce
--- /dev/null
+++ b/net-libs/liblockfile/liblockfile-1.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools multilib
+
+DESCRIPTION="Implements functions designed to lock the standard mailboxes"
+HOMEPAGE="http://www.debian.org/"
+SRC_URI="mirror://debian/pool/main/libl/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="acct-group/mail"
+DEPEND="${RDEPEND}"
+
+DOCS=( Changelog README )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.13-makefile.patch"
+)
+
+src_prepare() {
+ default
+
+ # I don't feel like making the Makefile portable
+ [[ ${CHOST} == *-darwin* ]] \
+ && cp "${FILESDIR}"/Makefile.Darwin.in Makefile.in
+
+ eautoreconf
+}
+
+src_configure() {
+ local grp=mail
+ if use prefix ; then
+ # we never want to use LDCONFIG
+ export LDCONFIG=${EPREFIX}/bin/true
+ # in unprivileged installs this is "mail"
+ grp=$(id -g)
+ fi
+ econf --with-mailgroup=${grp} --enable-shared
+}