summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2021-01-07 12:29:22 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-07 21:33:44 -0500
commit64ce94937cc7e8d4e13af758e6c7462bc170f73b (patch)
tree9ebb07f2cf2bffa6989f489ba5dfdc8947204078 /net-libs/libmbim
parentnet-libs/mbedtls: version bumps to 2.16.9 and 2.25.0, bug #764317 (diff)
downloadgentoo-64ce94937cc7e8d4e13af758e6c7462bc170f73b.tar.gz
gentoo-64ce94937cc7e8d4e13af758e6c7462bc170f73b.tar.bz2
gentoo-64ce94937cc7e8d4e13af758e6c7462bc170f73b.zip
net-libs/libmbim: 1.24.4 version bump
Closes: https://bugs.gentoo.org/710788 Closes: https://bugs.gentoo.org/761733 Closes: https://github.com/gentoo/gentoo/pull/18985 Signed-off-by: Craig Andrews <candrews@gentoo.org> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/libmbim')
-rw-r--r--net-libs/libmbim/Manifest1
-rw-r--r--net-libs/libmbim/libmbim-1.24.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/net-libs/libmbim/Manifest b/net-libs/libmbim/Manifest
index ba76b7a36bcf..92f4341d13a7 100644
--- a/net-libs/libmbim/Manifest
+++ b/net-libs/libmbim/Manifest
@@ -3,3 +3,4 @@ DIST libmbim-1.14.4.tar.xz 402924 BLAKE2B 0dec5cc540c2d57a5f98d2619c0c478c2b1377
DIST libmbim-1.16.0.tar.xz 453532 BLAKE2B 68732c02f7ee56d898895fe61a1aac44b0c1e858d5bd8fbc4a962429d86ffd1e58442f8ab7c74211d312cc8efb549d3dda14f2c13e16d5d12f8b790299d268be SHA512 90dcb4bf0e4d1d8da5f8bdc0d5a788b51775c55289c416e4dde1020dc353604a4ce40d723c500f8fb9099d7e9061b5c83148106dfd167128bae2cbafbda1279c
DIST libmbim-1.16.2.tar.xz 455096 BLAKE2B f29eaea16ab1f627ed7976fb84d6d1234bc58009e140e70e5ef4f3b9d2a37fcbc3a5492ccbf94d83c169cc64d4f7b545ce556704ce3c750bc00da80d5431119d SHA512 6081a5b40b7fc5cd21adf1948c16c57919c452bc2eccdccb561412ecada5aca7ff1fcac79568eb3dda83d49c780b0dab95a0b15bda0c4f2712b735cbe95402be
DIST libmbim-1.18.0.tar.xz 474768 BLAKE2B 3dce8e1fa0e57cdf75174d0145006b38213fcd2de9166589f2d3ddd7a17dae3b308ce7a7338d388543c8ba83b6a9d2bf12051cbde1666fc43580314d9906704b SHA512 510af324563a6a4f9a9d656d6724398cf5c5ba07424962d5407dd05867ef36da40e1ee6c8be8040c6a67e764bc059d24282db45ce3d47075fcf4d7416245b28d
+DIST libmbim-1.24.4.tar.xz 512524 BLAKE2B 4f91d1fd4d993b3e28f7508f4fbc3d6f4467db1c27307a3c4bd006ad9cdb40800513641fabf37deb673f5926d7a0f0d4806e3bd62a3ad8825227631d35c67d5b SHA512 bb0b82c64213e5b382a807c5c4c36751138c343419dc6abf1605573c91620af1a6de45587eab7341265f950548924fa65fa4bfedba0659b2f9eb80fa23ae88bc
diff --git a/net-libs/libmbim/libmbim-1.24.4.ebuild b/net-libs/libmbim/libmbim-1.24.4.ebuild
new file mode 100644
index 000000000000..6aa324455bcc
--- /dev/null
+++ b/net-libs/libmbim/libmbim-1.24.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib
+
+DESCRIPTION="Mobile Broadband Interface Model (MBIM) modem protocol helper library"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libmbim/ https://gitlab.freedesktop.org/mobile-broadband/libmbim"
+SRC_URI="https://www.freedesktop.org/software/libmbim/${P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="udev"
+
+RDEPEND=">=dev-libs/glib-2.48:2
+ udev? ( dev-libs/libgudev:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ --disable-Werror \
+ --disable-static \
+ --disable-gtk-doc \
+ $(use_with udev)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}