summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2021-01-03 16:48:07 +0300
committerAnthony G. Basile <blueness@gentoo.org>2021-01-03 11:50:02 -0500
commit5f53969bc19474dbeb1b96cf070e5d02870854a3 (patch)
tree36996b96dd58878182384c3c2a08266b6708007d /net-libs/libmicrohttpd
parentmedia-libs/kquickimageeditor: Drop -Werror (diff)
downloadgentoo-5f53969bc19474dbeb1b96cf070e5d02870854a3.tar.gz
gentoo-5f53969bc19474dbeb1b96cf070e5d02870854a3.tar.bz2
gentoo-5f53969bc19474dbeb1b96cf070e5d02870854a3.zip
net-libs/libmicrohttpd: bump to 0.9.72
Added USE flag 'thread-names' Added suggestion of myself as proxied maintainer Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'net-libs/libmicrohttpd')
-rw-r--r--net-libs/libmicrohttpd/Manifest1
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.72.ebuild55
-rw-r--r--net-libs/libmicrohttpd/metadata.xml7
3 files changed, 62 insertions, 1 deletions
diff --git a/net-libs/libmicrohttpd/Manifest b/net-libs/libmicrohttpd/Manifest
index e30a5d051b4c..9fc2402c1021 100644
--- a/net-libs/libmicrohttpd/Manifest
+++ b/net-libs/libmicrohttpd/Manifest
@@ -3,3 +3,4 @@ DIST libmicrohttpd-0.9.68.tar.gz 1884342 BLAKE2B 3f74c48917fa19753a617242fa07b99
DIST libmicrohttpd-0.9.69.tar.gz 1884511 BLAKE2B 6470b52e58d82a7fee17d8545e546cb9d3fa38012bcf3380d238afdf0f1b5391e19df53a89ac977ac9452d23610dc851f5da5972cace8d8f1088e1040d173572 SHA512 1633d2e606f476489e8af549fff88735e3b5641c85d59071edc8b2e1177fe1b6302578b69b8ff6669d3e1954c20cf0fa1ee52b42378362edd26197d8992e469b
DIST libmicrohttpd-0.9.70.tar.gz 1886435 BLAKE2B 09ae33c66f151d9ce03b8333b26c32e2c0896d150441f39da632fe1316c66123f343d021d7fc9a974fbbab7e642d253138d071d4ee506477de46bffd3ce4691c SHA512 391293688d5ef51cf8d918294000384cb291f46bf767295af5a97123c06c75573d480a6c4b2486712b53636fe3e5dc1f8827ccf4335ac435ec85c3529733d8f5
DIST libmicrohttpd-0.9.71.tar.gz 1894695 BLAKE2B 46bee477972a1bf791f9edaa7451790e03fccfac9a8b79fd6fb4038fbd2c3c0f268df787894cd21ddba2640fa087537f681dec4765fe03064a3c9f79aa708b26 SHA512 dab92c0979f8016844970ce4e110469e608e2e15b4096cf518350541248f123e40a4c0289ba025302e318e0bf47a957e9a3dcdee6f55936504b6c1c4f02efb86
+DIST libmicrohttpd-0.9.72.tar.gz 1693553 BLAKE2B 24d9284d8cab65d4a5b6b7f3a5b860dfd8cf69b21e44ee05ae2f7561b766a72d2dbb7f57849a31c22454e211befa74e058f78814b79e7876b3d14c7252ab5800 SHA512 9695e2fb08785e4b60342226ef3a0af22da4d80f127e7db9ec80ce844f70d0d781b30af207d58d8eb691b85a5fe4691cb9ecf887ca86f5e059a05259ae041316
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.72.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.72.ebuild
new file mode 100644
index 000000000000..c75cdb3d9195
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.72.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+epoll ssl static-libs test thread-names"
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? ( >net-libs/gnutls-2.12.20 )"
+
+DEPEND="${RDEPEND}
+ test? ( net-misc/curl[ssl?] )
+ virtual/pkgconfig
+ "
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ --disable-nls \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --enable-messages \
+ --enable-postprocessor \
+ --enable-httpupgrade \
+ --disable-experimental \
+ $(use_enable thread-names) \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls)
+}
+
+multilib_src_install_all() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}
diff --git a/net-libs/libmicrohttpd/metadata.xml b/net-libs/libmicrohttpd/metadata.xml
index 02fc68dc4f86..eb2da6137a91 100644
--- a/net-libs/libmicrohttpd/metadata.xml
+++ b/net-libs/libmicrohttpd/metadata.xml
@@ -5,9 +5,14 @@
<email>blueness@gentoo.org</email>
<name>Anthony G. Basile</name>
</maintainer>
+ <maintainer type="person">
+ <email>k2k@narod.ru</email>
+ <name>Evgeny Grin</name>
+ </maintainer>
<use>
<flag name="messages">enable error messages</flag>
- <flag name="epoll">use epoll() system call</flag>
+ <flag name="epoll">Use epoll() system call</flag>
+ <flag name="thread-names">Assign thread names to internal threads</flag>
</use>
<upstream>
<remote-id type="cpe">cpe:/a:gnu:libmicrohttpd</remote-id>