summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-06-30 11:33:47 -0700
committerMatt Turner <mattst88@gentoo.org>2020-06-30 11:35:56 -0700
commita54b2bf9602081ed050eaad1d700c21f8a50de17 (patch)
tree0a7f42ab5a3de4bc717b07ac0686a236fc05abba /net-libs/libmicrohttpd
parentapp-backup/borgmatic: Do not mention upgrade-borgmatic-config (diff)
downloadgentoo-a54b2bf9602081ed050eaad1d700c21f8a50de17.tar.gz
gentoo-a54b2bf9602081ed050eaad1d700c21f8a50de17.tar.bz2
gentoo-a54b2bf9602081ed050eaad1d700c21f8a50de17.zip
Revert "net-libs/libmicrohttpd: remove older versions"
The only stable version on sparc was removed because sparc@ was never Cc'd in the stabilization bug (#725362). This reverts commit ffb7a83f4a19f43f32c6ee3640c46917d6a31e3b. Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/libmicrohttpd')
-rw-r--r--net-libs/libmicrohttpd/Manifest3
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.65.ebuild61
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.68.ebuild61
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.69.ebuild61
-rw-r--r--net-libs/libmicrohttpd/metadata.xml1
5 files changed, 187 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/Manifest b/net-libs/libmicrohttpd/Manifest
index 9d74dc3a0a14..e30a5d051b4c 100644
--- a/net-libs/libmicrohttpd/Manifest
+++ b/net-libs/libmicrohttpd/Manifest
@@ -1,2 +1,5 @@
+DIST libmicrohttpd-0.9.65.tar.gz 1633346 BLAKE2B ce6ba2b6c52e30194872c66ab5b9e358f0979dd99ef24ce59fddf9e6fc2b76b01f424f9c9b511cf88c2dde2ca98d3f6a25cbcd26bdfadf0b9db65efd36435dc7 SHA512 751b7a5970cef07f260660254bfdeda4882e9e28d5cbdfbfed50e2c4583caf8f19c96ede6d368babc4223e7fbdf85d85eec37dc96abf333377dc13d6a9c6be12
+DIST libmicrohttpd-0.9.68.tar.gz 1884342 BLAKE2B 3f74c48917fa19753a617242fa07b99a69510a14a802609d038964d927516f8f52b4330d0eee2c7b98096b2d840158e4945310edef290224ea256d9616fb4d94 SHA512 9daaab5fb35fef6f2a19b7e08eeb8473aeb0a67631808a8d7a7f78a09cb621ca5d32dbbbca616865a40afb92f8c6495f9e2ba1674880af8011a2bc798c070a13
+DIST libmicrohttpd-0.9.69.tar.gz 1884511 BLAKE2B 6470b52e58d82a7fee17d8545e546cb9d3fa38012bcf3380d238afdf0f1b5391e19df53a89ac977ac9452d23610dc851f5da5972cace8d8f1088e1040d173572 SHA512 1633d2e606f476489e8af549fff88735e3b5641c85d59071edc8b2e1177fe1b6302578b69b8ff6669d3e1954c20cf0fa1ee52b42378362edd26197d8992e469b
DIST libmicrohttpd-0.9.70.tar.gz 1886435 BLAKE2B 09ae33c66f151d9ce03b8333b26c32e2c0896d150441f39da632fe1316c66123f343d021d7fc9a974fbbab7e642d253138d071d4ee506477de46bffd3ce4691c SHA512 391293688d5ef51cf8d918294000384cb291f46bf767295af5a97123c06c75573d480a6c4b2486712b53636fe3e5dc1f8827ccf4335ac435ec85c3529733d8f5
DIST libmicrohttpd-0.9.71.tar.gz 1894695 BLAKE2B 46bee477972a1bf791f9edaa7451790e03fccfac9a8b79fd6fb4038fbd2c3c0f268df787894cd21ddba2640fa087537f681dec4765fe03064a3c9f79aa708b26 SHA512 dab92c0979f8016844970ce4e110469e608e2e15b4096cf518350541248f123e40a4c0289ba025302e318e0bf47a957e9a3dcdee6f55936504b6c1c4f02efb86
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.65.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.65.ebuild
new file mode 100644
index 000000000000..e8edd69c90fc
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.65.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/12"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
+IUSE="+epoll messages ssl static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls
+ )"
+
+# We disable tests below because they're broken,
+# but if enabled, we'll need this.
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( net-misc/curl[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --enable-postprocessor \
+ --disable-thread-names \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+# tests are broken in the portage environment.
+src_test() {
+ :
+}
+
+multilib_src_install_all() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.68.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.68.ebuild
new file mode 100644
index 000000000000..455a6c307e14
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.68.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/12"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~sparc x86"
+IUSE="+epoll ssl static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls
+ )"
+
+# We disable tests below because they're broken,
+# but if enabled, we'll need this.
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( net-misc/curl[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --enable-messages \
+ --enable-postprocessor \
+ --disable-thread-names \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+# tests are broken in the portage environment.
+src_test() {
+ :
+}
+
+multilib_src_install_all() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.69.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.69.ebuild
new file mode 100644
index 000000000000..c17a93c12ff6
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.69.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+epoll ssl static-libs test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls
+ )"
+
+# We disable tests below because they're broken,
+# but if enabled, we'll need this.
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( net-misc/curl[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --enable-messages \
+ --enable-postprocessor \
+ --disable-thread-names \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+# tests are broken in the portage environment.
+src_test() {
+ :
+}
+
+multilib_src_install_all() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}
diff --git a/net-libs/libmicrohttpd/metadata.xml b/net-libs/libmicrohttpd/metadata.xml
index 11dcf85eaaed..02fc68dc4f86 100644
--- a/net-libs/libmicrohttpd/metadata.xml
+++ b/net-libs/libmicrohttpd/metadata.xml
@@ -6,6 +6,7 @@
<name>Anthony G. Basile</name>
</maintainer>
<use>
+ <flag name="messages">enable error messages</flag>
<flag name="epoll">use epoll() system call</flag>
</use>
<upstream>