summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2019-06-11 12:37:27 -0400
committerAnthony G. Basile <blueness@gentoo.org>2019-06-11 12:39:05 -0400
commitcc9a7cbdfef666bead80ec761ff4e5e5ddc4eaa0 (patch)
tree3cf05b7bb798ddf7b3ad2203b15b0e760c5ab627 /net-libs/libmicrohttpd
parentapp-text/texlive-core: Drop forced die on fmtutil-sys (diff)
downloadgentoo-cc9a7cbdfef666bead80ec761ff4e5e5ddc4eaa0.tar.gz
gentoo-cc9a7cbdfef666bead80ec761ff4e5e5ddc4eaa0.tar.bz2
gentoo-cc9a7cbdfef666bead80ec761ff4e5e5ddc4eaa0.zip
net-libs/libmicrohttpd: version bump to 0.9.64
Signed-off-by: Anthony G. Basile <blueness@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'net-libs/libmicrohttpd')
-rw-r--r--net-libs/libmicrohttpd/Manifest1
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.64.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/net-libs/libmicrohttpd/Manifest b/net-libs/libmicrohttpd/Manifest
index 1a12ea25e1de..0b7ab336411f 100644
--- a/net-libs/libmicrohttpd/Manifest
+++ b/net-libs/libmicrohttpd/Manifest
@@ -3,3 +3,4 @@ DIST libmicrohttpd-0.9.60.tar.gz 1818383 BLAKE2B 693da0a02e289000bb657d843cd5773
DIST libmicrohttpd-0.9.61.tar.gz 1823891 BLAKE2B d7704f36790b7f14e03a02b7fbc5eaaca5fc22702f1fadfc94f9fe05329505d5bf9422a1ff38daa1f33c82db3e1196a8db754227574cc2cb9441c08a50d65d72 SHA512 d409ca2164a55b0eab948a8a4a17e0d6547942039354f593b293a286a3cae247bd67d7de4ce0dd4f1a3f3684948250076f582a8086546eb72598a43d7f41a27d
DIST libmicrohttpd-0.9.62.tar.gz 1837529 BLAKE2B eb06d6ee05af2b37909ad1c60e16de29d94278a7ffea6e7b98391330e3778950537f9c2d6b057186b4ed45af66853570c0a386b6e9b1f0164956bd0856ecbaa5 SHA512 337f29dbc5e8c30132c17aad6142f21ea1c794b0ce80a3fc4c5e1e14b3dabb300aa410bf9413ef9e65d5d486fcfedbc3716725763a1fa28b4687c9f2aa3158e4
DIST libmicrohttpd-0.9.63.tar.gz 1840005 BLAKE2B 0fdbc97901a3c5fd9567e70c58e3ef93517a2b7defd88313329fd2e9c8f610e41524291e877ba6633339a29df4f17a735416904651163c272eb2334fa5012f11 SHA512 cb99e7af84fb6d7c0fd3894a9dc0fbff14959b35347506bd3211a65bbfad36455007b9e67493e97c9d8394834408df10eeabdc7758573e6aae0ba6f5f87afe17
+DIST libmicrohttpd-0.9.64.tar.gz 1631384 BLAKE2B 15437188f0246ea0270338e45016c344d345c31954256b70de73a16d6858bf7eff03b796214463cd5e34c5c9f8b47e84fcfb80550659d3579031eb3697e8555c SHA512 2569bcfcbc16da988a236fe337b60c0c69c23e7e66e9c9459b26b0b09a4763a42e94db11c9f10fbaf424bdce2b60e7d2837ecdd65393134ff5bc06f8b23c6bd9
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.64.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.64.ebuild
new file mode 100644
index 000000000000..7b1be999f8eb
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.64.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit multilib-minimal
+
+MY_P="${P/_/}"
+
+DESCRIPTION="Small C library to run an HTTP server as part of another application"
+HOMEPAGE="https://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="epoll messages ssl static-libs test"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt:0=
+ net-libs/gnutls
+ )"
+
+# We disable tests below because they're broken,
+# but if enabled, we'll need this.
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( net-misc/curl[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-examples \
+ --enable-postprocessor \
+ --disable-thread-names \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+# tests are broken in the portage environment.
+src_test() {
+ :
+}
+
+multilib_src_install_all() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -delete
+}