summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-12-12 21:38:19 -0500
committerAaron Bauman <bman@gentoo.org>2019-12-12 22:25:06 -0500
commitf8c71641924952b7d4a38155d8897378b264ca18 (patch)
tree8fe9413f8b5282a5390fe95a49255efa5b0c9531 /net-libs/libmnl
parentnet-libs/courier-authlib: drop old EAPI (diff)
downloadgentoo-f8c71641924952b7d4a38155d8897378b264ca18.tar.gz
gentoo-f8c71641924952b7d4a38155d8897378b264ca18.tar.bz2
gentoo-f8c71641924952b7d4a38155d8897378b264ca18.zip
net-libs/libmnl: port to EAPI 7
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'net-libs/libmnl')
-rw-r--r--net-libs/libmnl/libmnl-1.0.3-r1.ebuild12
-rw-r--r--net-libs/libmnl/libmnl-1.0.4.ebuild9
2 files changed, 12 insertions, 9 deletions
diff --git a/net-libs/libmnl/libmnl-1.0.3-r1.ebuild b/net-libs/libmnl/libmnl-1.0.3-r1.ebuild
index 316073b5786e..67fbdb2cc36f 100644
--- a/net-libs/libmnl/libmnl-1.0.3-r1.ebuild
+++ b/net-libs/libmnl/libmnl-1.0.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils toolchain-funcs usr-ldscript
+inherit toolchain-funcs usr-ldscript
DESCRIPTION="Minimalistic netlink library"
HOMEPAGE="https://netfilter.org/projects/libmnl/"
@@ -20,11 +20,13 @@ src_configure() {
src_install() {
default
+
gen_usr_ldscript -a mnl
- prune_libtool_files
+
+ find "${D}" -name '*.la' -delete || die
if use examples; then
- find examples/ -name 'Makefile*' -delete
+ find examples/ -name 'Makefile*' -delete || die
dodoc -r examples/
docompress -x /usr/share/doc/${PF}/examples
fi
diff --git a/net-libs/libmnl/libmnl-1.0.4.ebuild b/net-libs/libmnl/libmnl-1.0.4.ebuild
index fd97a5559d26..794d9e309842 100644
--- a/net-libs/libmnl/libmnl-1.0.4.ebuild
+++ b/net-libs/libmnl/libmnl-1.0.4.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs usr-ldscript
+inherit toolchain-funcs usr-ldscript
DESCRIPTION="Minimalistic netlink library"
HOMEPAGE="https://netfilter.org/projects/libmnl/"
@@ -22,10 +22,11 @@ src_install() {
default
gen_usr_ldscript -a mnl
- prune_libtool_files
+
+ find "${D}" -name '*.la' -delete || die
if use examples; then
- find examples/ -name 'Makefile*' -delete
+ find examples/ -name 'Makefile*' -delete || die
dodoc -r examples/
docompress -x /usr/share/doc/${PF}/examples
fi