summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libnet/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libnet/files')
-rw-r--r--net-libs/libnet/files/1.0.2a-endian.patch20
-rw-r--r--net-libs/libnet/files/1.0.2a-slot.patch189
-rw-r--r--net-libs/libnet/files/libnet-1.2-rc.patch11
-rw-r--r--net-libs/libnet/files/libnet-gcc33-fix13
4 files changed, 233 insertions, 0 deletions
diff --git a/net-libs/libnet/files/1.0.2a-endian.patch b/net-libs/libnet/files/1.0.2a-endian.patch
new file mode 100644
index 000000000000..aad0bacb2f2e
--- /dev/null
+++ b/net-libs/libnet/files/1.0.2a-endian.patch
@@ -0,0 +1,20 @@
+--- a/include/libnet.h
++++ b/include/libnet.h
+@@ -32,6 +32,17 @@
+ #ifndef __LIBNET_H
+ #define __LIBNET_H
+
++#include <endian.h>
++#if __BYTE_ORDER == __LITTLE_ENDIAN
++# define LIBNET_LIL_ENDIAN 1
++#else
++# if __BYTE_ORDER == __BIG_ENDIAN
++# define LIBNET_BIG_ENDIAN 1
++# else
++# error unrecognized __BYTE_ORDER
++# endif
++#endif
++
+ #include <stdio.h>
+ #include <string.h>
+ #include <unistd.h>
diff --git a/net-libs/libnet/files/1.0.2a-slot.patch b/net-libs/libnet/files/1.0.2a-slot.patch
new file mode 100644
index 000000000000..bcc0d56113f5
--- /dev/null
+++ b/net-libs/libnet/files/1.0.2a-slot.patch
@@ -0,0 +1,189 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -18,17 +18,17 @@
+ LIB_PREFIX = @libdir@/
+ MAN_PREFIX = @MAN_PREFIX@
+
+-LIBNET = libnet
+-LIBPWRITE = libpwrite
++LIBNET = libnet-1.0
++LIBPWRITE = libpwrite-1.0
+ LIB = lib/$(LIBNET).a
+ MAN = doc/$(LIBNET).3
+ INCLUDE = include/$(LIBNET).h
+-INCLUDE-H = include/$(LIBNET)/$(LIBNET)-headers.h
+-INCLUDE-F = include/$(LIBNET)/$(LIBNET)-functions.h
+-INCLUDE-S = include/$(LIBNET)/$(LIBNET)-structures.h
+-INCLUDE-M = include/$(LIBNET)/$(LIBNET)-macros.h
+-INCLUDE-A = include/$(LIBNET)/$(LIBNET)-asn1.h
+-INCLUDE-O = include/$(LIBNET)/$(LIBNET)-ospf.h
++INCLUDE-H = include/libnet/$(LIBNET)-headers.h
++INCLUDE-F = include/libnet/$(LIBNET)-functions.h
++INCLUDE-S = include/libnet/$(LIBNET)-structures.h
++INCLUDE-M = include/libnet/$(LIBNET)-macros.h
++INCLUDE-A = include/libnet/$(LIBNET)-asn1.h
++INCLUDE-O = include/libnet/$(LIBNET)-ospf.h
+ CONFIG = $(LIBNET)-config
+ DEFINES += @DEFS@
+ RANLIB = @RANLIB@
+@@ -94,7 +94,7 @@
+ install: libnet
+ $(ENSUREDIR) $(DESTDIR)$(prefix) 755
+ $(ENSUREDIR) $(DESTDIR)$(LIB_PREFIX) 755
+- $(ENSUREDIR) $(DESTDIR)$(INC_PREFIX)$(LIBNET) 755
++ $(ENSUREDIR) $(DESTDIR)$(INC_PREFIX)/libnet/ 755
+ $(ENSUREDIR) $(DESTDIR)$(INC_PREFIX) 755
+ $(ENSUREDIR) $(DESTDIR)$(MAN_PREFIX) 755
+ $(ENSUREDIR) $(DESTDIR)$(BIN_PREFIX) 755
+@@ -102,12 +102,12 @@
+ rm -f $(DESTDIR)$(LIB_PREFIX)$(LIBPWRITE).a
+ cd $(DESTDIR)$(LIB_PREFIX); $(LN) -f -s $(LIBNET).a $(LIBPWRITE).a
+ $(INSTALL_DATA) $(INCLUDE) $(DESTDIR)$(INC_PREFIX)
+- $(INSTALL_DATA) $(INCLUDE-H) $(DESTDIR)$(INC_PREFIX)$(LIBNET)
+- $(INSTALL_DATA) $(INCLUDE-F) $(DESTDIR)$(INC_PREFIX)$(LIBNET)
+- $(INSTALL_DATA) $(INCLUDE-S) $(DESTDIR)$(INC_PREFIX)$(LIBNET)
+- $(INSTALL_DATA) $(INCLUDE-M) $(DESTDIR)$(INC_PREFIX)$(LIBNET)
+- $(INSTALL_DATA) $(INCLUDE-A) $(DESTDIR)$(INC_PREFIX)$(LIBNET)
+- $(INSTALL_DATA) $(INCLUDE-O) $(DESTDIR)$(INC_PREFIX)$(LIBNET)
++ $(INSTALL_DATA) $(INCLUDE-H) $(DESTDIR)$(INC_PREFIX)/libnet/
++ $(INSTALL_DATA) $(INCLUDE-F) $(DESTDIR)$(INC_PREFIX)/libnet/
++ $(INSTALL_DATA) $(INCLUDE-S) $(DESTDIR)$(INC_PREFIX)/libnet/
++ $(INSTALL_DATA) $(INCLUDE-M) $(DESTDIR)$(INC_PREFIX)/libnet/
++ $(INSTALL_DATA) $(INCLUDE-A) $(DESTDIR)$(INC_PREFIX)/libnet/
++ $(INSTALL_DATA) $(INCLUDE-O) $(DESTDIR)$(INC_PREFIX)/libnet/
+ $(INSTALL_DATA) $(MAN) $(DESTDIR)$(MAN_PREFIX)
+ $(INSTALL_DATA) $(CONFIG) $(DESTDIR)$(BIN_PREFIX)
+
+@@ -142,6 +142,6 @@
+ cd support/bpf-lkm/etherspoof && rm -rf Makefile; \
+ fi
+ rm -f config.log config.cache config.status Makefile include/config.h \
+- version.h support/bpf-lkm/etherspoof conftest* libnet-config
++ version.h support/bpf-lkm/etherspoof conftest* libnet-1.0-config
+
+ # EOF
+--- a/configure.in
++++ b/configure.in
+@@ -261,6 +261,6 @@
+ AC_OUTPUT(Makefile test/Makefile test/TCP/Makefile test/Ethernet/Makefile \
+ test/UDP/Makefile test/ICMP/Makefile test/Random/Makefile \
+ test/OSPF/Makefile util/Makefile util/Get-mac/Makefile example/Makefile \
+- libnet-config, chmod +x libnet-config)
++ libnet-1.0-config, chmod +x libnet-1.0-config)
+
+ dnl EOF
+--- a/include/libnet.h
++++ b/include/libnet.h
+@@ -74,12 +74,12 @@
+ #include <errno.h>
+ #include <assert.h>
+
+-#include "./libnet/libnet-headers.h"
+-#include "./libnet/libnet-structures.h"
+-#include "./libnet/libnet-macros.h"
+-#include "./libnet/libnet-asn1.h"
+-#include "./libnet/libnet-functions.h"
+-#include "./libnet/libnet-ospf.h"
++#include "./libnet/libnet-1.0-headers.h"
++#include "./libnet/libnet-1.0-structures.h"
++#include "./libnet/libnet-1.0-macros.h"
++#include "./libnet/libnet-1.0-asn1.h"
++#include "./libnet/libnet-1.0-functions.h"
++#include "./libnet/libnet-1.0-ospf.h"
+
+ #define LIBNET_VERSION "1.0.2a"
+
+--- a/libnet-config.in
++++ b/libnet-config.in
+@@ -9,12 +9,12 @@
+
+ libnet_defines="@LIBNET_CONFIG_DEFINES@"
+ libnet_cflags="@LIBNET_CONFIG_CFLAGS@"
+-libnet_libs="@LIBNET_CONFIG_LIBS@ -lnet"
++libnet_libs="@LIBNET_CONFIG_LIBS@ -lnet-1.0"
+
+ usage()
+ {
+ cat <<EOF
+-Usage: libnet-config [OPTIONS]
++Usage: libnet-1.0-config [OPTIONS]
+ Options:
+ [--libs]
+ [--cflags]
+--- a/test/Ethernet/Makefile.in
++++ b/test/Ethernet/Makefile.in
+@@ -10,7 +10,7 @@
+ CFLAGS = @CFLAGS@
+ OBJECTS = arp.o tcp.o icmp_mask.o get_address.o poink.o
+ DEFINES += @DEFS@
+-LIBS = -L../../lib/ -lnet @ADDITIONAL_LIBS@
++LIBS = -L../../lib/ -lnet-1.0 @ADDITIONAL_LIBS@
+
+ .c.o:
+ $(CC) $(CFLAGS) $(DEFINES) -c $< -o $@
+--- a/test/ICMP/Makefile.in
++++ b/test/ICMP/Makefile.in
+@@ -15,7 +15,7 @@
+ ping_of_death.o
+
+ DEFINES += @DEFS@
+-LIBS = -L../../lib/ -lnet @ADDITIONAL_LIBS@
++LIBS = -L../../lib/ -lnet-1.0 @ADDITIONAL_LIBS@
+
+ .c.o:
+ $(CC) $(CFLAGS) $(DEFINES) -c $< -o $@
+--- a/test/IP/Makefile.in
++++ b/test/IP/Makefile.in
+@@ -10,7 +10,7 @@
+ OBJECTS =
+
+ DEFINES += @DEFS@
+-LIBS = -L../../lib/ -lnet @ADDITIONAL_LIBS@
++LIBS = -L../../lib/ -lnet-1.0 @ADDITIONAL_LIBS@
+
+ .c.o:
+ $(CC) $(CFLAGS) $(DEFINES) -c $< -o $@
+--- a/test/OSPF/Makefile.in
++++ b/test/OSPF/Makefile.in
+@@ -12,7 +12,7 @@
+ ospf_request.o \
+
+ DEFINES += @DEFS@
+-LIBS = -L../../lib/ -lnet @ADDITIONAL_LIBS@
++LIBS = -L../../lib/ -lnet-1.0 @ADDITIONAL_LIBS@
+
+ .c.o:
+ $(CC) $(CFLAGS) $(DEFINES) -c $< -o $@
+--- a/test/Random/Makefile.in
++++ b/test/Random/Makefile.in
+@@ -9,7 +9,7 @@
+ CFLAGS = @CFLAGS@
+ OBJECTS = prand_trials.o
+ DEFINES += @DEFS@
+-LIBS = -L../../lib/ -lnet @ADDITIONAL_LIBS@
++LIBS = -L../../lib/ -lnet-1.0 @ADDITIONAL_LIBS@
+
+ .c.o:
+ $(CC) $(CFLAGS) $(DEFINES) -c $< -o $@
+--- a/test/TCP/Makefile.in
++++ b/test/TCP/Makefile.in
+@@ -13,7 +13,7 @@
+ tcp+data+ipopt.o
+
+ DEFINES += @DEFS@
+-LIBS = -L../../lib/ -lnet @ADDITIONAL_LIBS@
++LIBS = -L../../lib/ -lnet-1.0 @ADDITIONAL_LIBS@
+
+ .c.o:
+ $(CC) $(CFLAGS) $(DEFINES) -c $< -o $@
+--- a/test/UDP/Makefile.in
++++ b/test/UDP/Makefile.in
+@@ -11,7 +11,7 @@
+ udp+data.o
+
+ DEFINES += @DEFS@
+-LIBS = -L../../lib/ -lnet @ADDITIONAL_LIBS@
++LIBS = -L../../lib/ -lnet-1.0 @ADDITIONAL_LIBS@
+
+ .c.o:
+ $(CC) $(CFLAGS) $(DEFINES) -c $< -o $@
diff --git a/net-libs/libnet/files/libnet-1.2-rc.patch b/net-libs/libnet/files/libnet-1.2-rc.patch
new file mode 100644
index 000000000000..b9e44a3491cb
--- /dev/null
+++ b/net-libs/libnet/files/libnet-1.2-rc.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,7 +4,7 @@
+ dnl
+ dnl Process this file with autoconf to produce a configure script.
+
+-AC_INIT([libnet],[1.2-rc3])
++AC_INIT([libnet],[1.2])
+ AC_MSG_RESULT(beginning autoconfiguration process for libnet-${PACKAGE_VERSION} ...)
+ AC_CANONICAL_TARGET
+ AC_CONFIG_SRCDIR([src/libnet_build_ip.c])
diff --git a/net-libs/libnet/files/libnet-gcc33-fix b/net-libs/libnet/files/libnet-gcc33-fix
new file mode 100644
index 000000000000..6f711abc8ebf
--- /dev/null
+++ b/net-libs/libnet/files/libnet-gcc33-fix
@@ -0,0 +1,13 @@
+--- Libnet-1.0.2a-orig/include/libnet.h 2001-02-07 00:19:25.000000000 +0100
++++ Libnet-1.0.2a/include/libnet.h 2003-07-24 18:34:33.000000000 +0200
+@@ -84,8 +84,8 @@
+ #define LIBNET_VERSION "1.0.2a"
+
+ #if (!LIBNET_LIL_ENDIAN && !LIBNET_BIG_ENDIAN)
+-#error "byte order has not been specified, you'll
+-need to #define either LIBNET_LIL_ENDIAN or LIBNET_BIG_ENDIAN. See the
++#error "byte order has not been specified, you'll \
++need to #define either LIBNET_LIL_ENDIAN or LIBNET_BIG_ENDIAN. See the \
+ documentation regarding the libnet-config script."
+ #endif
+