summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-27 01:53:03 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-27 01:54:20 +0100
commitecd205fb78fa52836a18d835c1468e0afd03b38d (patch)
treeead2e84258125c117bc2fb0e7015015e1b45aee6 /net-libs/libnet/files
parentnet-analyzer/hping: Fix CFLAGS=-fno-common (diff)
downloadgentoo-ecd205fb78fa52836a18d835c1468e0afd03b38d.tar.gz
gentoo-ecd205fb78fa52836a18d835c1468e0afd03b38d.tar.bz2
gentoo-ecd205fb78fa52836a18d835c1468e0afd03b38d.zip
net-libs/libnet: Old
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/libnet/files')
-rw-r--r--net-libs/libnet/files/libnet-1.1.6-musl.patch29
-rw-r--r--net-libs/libnet/files/libnet-1.2-_SOURCE.patch20
-rw-r--r--net-libs/libnet/files/libnet-1.2-rc.patch11
-rw-r--r--net-libs/libnet/files/libnet-1.2-sizeof.patch11
-rw-r--r--net-libs/libnet/files/libnet-1.2-socklen_t.patch11
5 files changed, 0 insertions, 82 deletions
diff --git a/net-libs/libnet/files/libnet-1.1.6-musl.patch b/net-libs/libnet/files/libnet-1.1.6-musl.patch
deleted file mode 100644
index 238fb8acbef1..000000000000
--- a/net-libs/libnet/files/libnet-1.1.6-musl.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/src/libnet_link_linux.c
-+++ b/src/libnet_link_linux.c
-@@ -30,26 +30,15 @@
- #include <sys/time.h>
-
- #include <net/if.h>
--#if (__GLIBC__)
- #include <netinet/if_ether.h>
- #include <net/if_arp.h>
--#else
--#include <linux/if_arp.h>
--#include <linux/if_ether.h>
--#endif
-
- #if (HAVE_PACKET_SOCKET)
- #ifndef SOL_PACKET
- #define SOL_PACKET 263
- #endif /* SOL_PACKET */
--#if __GLIBC__ >= 2 && __GLIBC_MINOR >= 1
- #include <netpacket/packet.h>
- #include <net/ethernet.h> /* the L2 protocols */
--#else
--#include <asm/types.h>
--#include <linux/if_packet.h>
--#include <linux/if_ether.h> /* The L2 protocols */
--#endif
- #endif /* HAVE_PACKET_SOCKET */
-
- #include "../include/libnet.h"
diff --git a/net-libs/libnet/files/libnet-1.2-_SOURCE.patch b/net-libs/libnet/files/libnet-1.2-_SOURCE.patch
deleted file mode 100644
index d9c74f40e300..000000000000
--- a/net-libs/libnet/files/libnet-1.2-_SOURCE.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -157,14 +157,14 @@
- case "$target_os" in
-
- *linux*)
-- AC_DEFINE(_BSD_SOURCE, 1,
-+ AC_DEFINE(_DEFAULT_SOURCE, 1,
- [Define as necessary to "unhide" header symbols.])
-- AC_DEFINE(__BSD_SOURCE, 1,
-+ AC_DEFINE(__DEFAULT_SOURCE, 1,
- [Define as necessary to "unhide" header symbols.])
- AC_DEFINE(__FAVOR_BSD, 1,
- [Define if we should favor the BSD APIs when possible in Linux.])
-
-- LIBNET_CONFIG_DEFINES="-D_BSD_SOURCE -D__BSD_SOURCE -D__FAVOR_BSD"
-+ LIBNET_CONFIG_DEFINES="-D_DEFAULT_SOURCE -D__DEFAULT_SOURCE -D__FAVOR_BSD"
- AC_CHECK_HEADERS(net/ethernet.h, \
- LIBNET_CONFIG_DEFINES="$LIBNET_CONFIG_DEFINES -DHAVE_NET_ETHERNET_H")
- ;;
diff --git a/net-libs/libnet/files/libnet-1.2-rc.patch b/net-libs/libnet/files/libnet-1.2-rc.patch
deleted file mode 100644
index b9e44a3491cb..000000000000
--- a/net-libs/libnet/files/libnet-1.2-rc.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -4,7 +4,7 @@
- dnl
- dnl Process this file with autoconf to produce a configure script.
-
--AC_INIT([libnet],[1.2-rc3])
-+AC_INIT([libnet],[1.2])
- AC_MSG_RESULT(beginning autoconfiguration process for libnet-${PACKAGE_VERSION} ...)
- AC_CANONICAL_TARGET
- AC_CONFIG_SRCDIR([src/libnet_build_ip.c])
diff --git a/net-libs/libnet/files/libnet-1.2-sizeof.patch b/net-libs/libnet/files/libnet-1.2-sizeof.patch
deleted file mode 100644
index 603224267fdf..000000000000
--- a/net-libs/libnet/files/libnet-1.2-sizeof.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/sample/sebek.c
-+++ b/sample/sebek.c
-@@ -167,7 +167,7 @@
-
- if (payload_flag)
- {
-- memset(cmd, 0, sizeof(cmd));
-+ memset(cmd, 0, length);
- memcpy(cmd, payload, (payload_s < 12 ? payload_s : 12));
- length = payload_s;
- }
diff --git a/net-libs/libnet/files/libnet-1.2-socklen_t.patch b/net-libs/libnet/files/libnet-1.2-socklen_t.patch
deleted file mode 100644
index bce36704477f..000000000000
--- a/net-libs/libnet/files/libnet-1.2-socklen_t.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/libnet_raw.c
-+++ b/src/libnet_raw.c
-@@ -77,7 +77,7 @@
- #else
- BOOL n;
- #endif
-- int len;
-+ socklen_t len;
-
- #ifdef SO_SNDBUF
-