summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2020-01-02 18:49:16 +0100
committerSam James <sam@gentoo.org>2021-03-15 21:08:56 +0000
commitebdc3396c4d25c2adbb919152b2712160427535a (patch)
treee26f711f0d4b80a4f4769f3a9bdf06722164ff1b /net-libs/libnet
parentnet-analyzer/nfdump: merge nfcapd changes into 1.6.22-r1 (diff)
downloadgentoo-ebdc3396c4d25c2adbb919152b2712160427535a.tar.gz
gentoo-ebdc3396c4d25c2adbb919152b2712160427535a.tar.bz2
gentoo-ebdc3396c4d25c2adbb919152b2712160427535a.zip
net-libs/libnet: add patch to support musl
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/14219 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libnet')
-rw-r--r--net-libs/libnet/files/libnet-1.2-int64_t.patch15
-rw-r--r--net-libs/libnet/libnet-1.2.ebuild4
2 files changed, 19 insertions, 0 deletions
diff --git a/net-libs/libnet/files/libnet-1.2-int64_t.patch b/net-libs/libnet/files/libnet-1.2-int64_t.patch
new file mode 100644
index 000000000000..b0b968fc3325
--- /dev/null
+++ b/net-libs/libnet/files/libnet-1.2-int64_t.patch
@@ -0,0 +1,15 @@
+--- a/include/libnet/libnet-structures.h
++++ b/include/libnet/libnet-structures.h
+@@ -49,9 +49,9 @@ struct libnet_port_list_chain
+ /* libnet statistics structure */
+ struct libnet_stats
+ {
+- __int64_t packets_sent; /* packets sent */
+- __int64_t packet_errors; /* packets errors */
+- __int64_t bytes_written; /* bytes written */
++ int64_t packets_sent; /* packets sent */
++ int64_t packet_errors; /* packets errors */
++ int64_t bytes_written; /* bytes written */
+ };
+
+
diff --git a/net-libs/libnet/libnet-1.2.ebuild b/net-libs/libnet/libnet-1.2.ebuild
index 7e47a083806d..7c9c1dba2b03 100644
--- a/net-libs/libnet/libnet-1.2.ebuild
+++ b/net-libs/libnet/libnet-1.2.ebuild
@@ -16,6 +16,10 @@ DOCS=(
ChangeLog.md README.md doc/MIGRATION.md
)
+# This patch is taken from master branch in mainstream commit a1659e2. It is
+# necessary in order to support musl libc.
+PATCHES=( "${FILESDIR}/${P}-int64_t.patch" )
+
src_configure() {
econf $(use_enable static-libs static)
}