summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-06-05 18:21:34 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-05 18:21:34 +0200
commitb30b2dbe0597f726588b6427c48b0afe662f985a (patch)
tree869e89bc1a9a84043dcb001545d386ca5dcc0fba /net-libs/libnetconf2
parentnet-libs/libyang: Bump to 1.0.240 (diff)
downloadgentoo-b30b2dbe0597f726588b6427c48b0afe662f985a.tar.gz
gentoo-b30b2dbe0597f726588b6427c48b0afe662f985a.tar.bz2
gentoo-b30b2dbe0597f726588b6427c48b0afe662f985a.zip
net-libs/libnetconf2: Bump to 1.1.46
Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/libnetconf2')
-rw-r--r--net-libs/libnetconf2/Manifest1
-rw-r--r--net-libs/libnetconf2/libnetconf2-1.1.46.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/net-libs/libnetconf2/Manifest b/net-libs/libnetconf2/Manifest
index 0d2a345ee669..b34b485307f2 100644
--- a/net-libs/libnetconf2/Manifest
+++ b/net-libs/libnetconf2/Manifest
@@ -1,2 +1,3 @@
DIST libnetconf2-1.1.43.tar.gz 295502 BLAKE2B 49bd58d785a0b7b132c4503b0b8a823ff3578e6e1d30e0c0e4aecf6ebb6f769f465069ebbfce7fd090e64e0b798ab8977535c634f45e677cec00d7c73edaee20 SHA512 2aff10ef003d5ee1f72a3c01a0fd07f7a1ac3b1961c88a9616632255d7392d386e0acad97fc68b3f5f1a0b4804dcb0900afa625208ab0dd33cf03706f7a89f5d
+DIST libnetconf2-1.1.46.tar.gz 295868 BLAKE2B ac20dd66c779b9b509f09c1a45224679e2b5701758cf04511c89be90c9ba065c1356c3f50026fa9f6a2f83530437b57ff38ff5977557a9faf61493e0d47f69df SHA512 e1ee152499113f267c3cefbb43f9049ba61fc97228311cb0a68f457aec620059132996fa1878a081e99cfc005d709954282729ace4e937644b4b557db3b3db97
DIST libnetconf2-2.0.1.tar.gz 292658 BLAKE2B d2821b4b66773b777764f7a453649a7ea60bacc418a8ff5c33e54b244a1f285b84ec8a1cc6d6285ff280c8631d79dfe9db352ad03781a7694762efd8545462ac SHA512 26f0a900387a8dbf5c12136d29529e7aba973dba4e1e3ff091cb70385a686533f041cfe647e273f6188b9494b67f771564b2e32f10e1fc61586112d88837f5c8
diff --git a/net-libs/libnetconf2/libnetconf2-1.1.46.ebuild b/net-libs/libnetconf2/libnetconf2-1.1.46.ebuild
new file mode 100644
index 000000000000..82bf4c2b9ca5
--- /dev/null
+++ b/net-libs/libnetconf2/libnetconf2-1.1.46.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C library for building NETCONF servers and clients"
+HOMEPAGE="https://github.com/CESNET/libnetconf2"
+SRC_URI="https://github.com/CESNET/libnetconf2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ >=net-libs/libyang-1.0.240:=
+ <net-libs/libyang-2.0.0:=
+ net-libs/libssh:0=[server]
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_BUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+
+ use doc && cmake_src_compile doc
+}
+
+src_install() {
+ cmake_src_install
+
+ use doc && dodoc -r doc/.
+}