summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-23 00:00:54 +0000
committerSam James <sam@gentoo.org>2022-03-23 00:00:54 +0000
commitd36aea6aa4041d7b5163a549dd433305b722c468 (patch)
treeda9842840021120a9ee8e91bb653e2c66bf62681 /net-libs/libnfsidmap/libnfsidmap-0.27.ebuild
parentapp-crypt/heimdal: add subslot dep on OpenLDAP (diff)
downloadgentoo-d36aea6aa4041d7b5163a549dd433305b722c468.tar.gz
gentoo-d36aea6aa4041d7b5163a549dd433305b722c468.tar.bz2
gentoo-d36aea6aa4041d7b5163a549dd433305b722c468.zip
net-libs/libnfsidmap: add subslot dep on OpenLDAP
New OpenLDAP breaks ABI (changes SONAME) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libnfsidmap/libnfsidmap-0.27.ebuild')
-rw-r--r--net-libs/libnfsidmap/libnfsidmap-0.27.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/net-libs/libnfsidmap/libnfsidmap-0.27.ebuild b/net-libs/libnfsidmap/libnfsidmap-0.27.ebuild
deleted file mode 100644
index e93e96fb27fb..000000000000
--- a/net-libs/libnfsidmap/libnfsidmap-0.27.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="NFSv4 ID <-> name mapping library"
-HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
-#SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/${P}.tar.gz"
-SRC_URI="https://fedorapeople.org/~steved/${PN}/${PV}/${P}.tar.bz2"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE="ldap static-libs"
-
-DEPEND="ldap? ( net-nds/openldap )"
-RDEPEND="
- ${DEPEND}
- !<net-fs/nfs-utils-1.2.2
- !net-fs/idmapd
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.27-getgrouplist.patch #169909
- "${FILESDIR}"/${PN}-0.21-headers.patch
-)
-
-src_prepare() {
- default
- # Ideally the build would use -DLIBDIR=$(libdir) at build time.
- sed -i \
- -e "/PATH_PLUGINS/s:/usr/lib/libnfsidmap:${EPREFIX}/usr/$(get_libdir)/libnfsidmap:" \
- libnfsidmap.c || die #504666
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_enable static-libs static)
- $(use_enable ldap)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- insinto /etc
- doins idmapd.conf
-
- # remove useless files
- rm -f "${ED%/}"/usr/$(get_libdir)/libnfsidmap/*.{a,la}
- use static-libs || find "${ED%/}"/usr -name '*.la' -delete || die
-}