summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-02 15:51:56 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-02 15:57:36 +0200
commita750b8d87d2077120aacd368207056a5e8516b28 (patch)
treea140555379cc7ad86e4766baef0eeb2bfa868360 /net-libs/libnftnl
parentdev-scheme/guile-lib: hppa stable wrt bug #647114 (diff)
downloadgentoo-a750b8d87d2077120aacd368207056a5e8516b28.tar.gz
gentoo-a750b8d87d2077120aacd368207056a5e8516b28.tar.bz2
gentoo-a750b8d87d2077120aacd368207056a5e8516b28.zip
net-libs/libnftnl: Bump to version 1.1.0
Closes: https://bugs.gentoo.org/654606 Package-Manager: Portage-2.3.33, Repoman-2.3.9
Diffstat (limited to 'net-libs/libnftnl')
-rw-r--r--net-libs/libnftnl/Manifest1
-rw-r--r--net-libs/libnftnl/libnftnl-1.1.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/libnftnl/Manifest b/net-libs/libnftnl/Manifest
index d39bcd44d6d8..b5d768b89423 100644
--- a/net-libs/libnftnl/Manifest
+++ b/net-libs/libnftnl/Manifest
@@ -1,2 +1,3 @@
DIST libnftnl-1.0.8.tar.bz2 400496 BLAKE2B d2563f707ceb40b8cd7c4b4fdede64943fabcc8a639eb61c844f7b941786a49b1c029e375977759717e5cb8f8dc2019ddcbf48223347f868713d1a077d51d8a8 SHA512 df9f5967908ce5e6a6a85fe4328bdf6e7501ce6b0e42239b750782aeb76c30b1aae80dd07f73a06fb077d072b1269c4e0c5fd525feed1055400201567d215ef9
DIST libnftnl-1.0.9.tar.bz2 402296 BLAKE2B 87d1fe9543c1451bf90bd8b2dd442d783649940f38cf10081acac46cd985bd0826f5d2eaab2af65b80ebd4b0a9bfd7dba53ff420fa0f6b901296aa02c746e3ca SHA512 ca4a9402fba8b1354314aed45637026afa4faf880991baf93b2b7e01ca7f44e75ffedc624728bd5a7aa1b30bcbb83b849d2f9aea55be7a18f49036653c08151b
+DIST libnftnl-1.1.0.tar.bz2 370642 BLAKE2B 3dbc0116027e863a656c55c0d65449bf3905378e84c907f0d94582c608a793952fbb83f90565304af05978b08675a6edf13ee997fd5ce0d4374a2143746691c1 SHA512 3216afbd62f5dbd78b26c2ab3acb467bca5d6a7f5fd5bb15356b9d80ffca64f9afa1d8f374701e00f1ae9e5ec282fd55c970502121330c1446032e70bb593d23
diff --git a/net-libs/libnftnl/libnftnl-1.1.0.ebuild b/net-libs/libnftnl/libnftnl-1.1.0.ebuild
new file mode 100644
index 000000000000..f9ff5b2f238f
--- /dev/null
+++ b/net-libs/libnftnl/libnftnl-1.1.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools linux-info toolchain-funcs
+
+DESCRIPTION="Netlink API to the in-kernel nf_tables subsystem"
+HOMEPAGE="https://netfilter.org/projects/nftables/"
+SRC_URI="https://netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/7" # libnftnl.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="examples json static-libs test threads"
+
+RDEPEND=">=net-libs/libmnl-1.0.0
+ json? ( >=dev-libs/jansson-2.3 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+REQUIRED_USE="test? ( json )"
+
+pkg_setup() {
+ if kernel_is ge 3 13; then
+ CONFIG_CHECK="~NF_TABLES"
+ linux-info_pkg_setup
+ else
+ eerror "This package requires kernel version 3.13 or newer to work properly."
+ fi
+}
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable static-libs static)
+ $(use_with json json-parsing)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ default
+ cd tests || die
+ ./test-script.sh || die
+}
+
+src_install() {
+ default
+ gen_usr_ldscript -a nftnl
+ find "${D}" -name '*.la' -delete || die "Could not rm libtool files"
+
+ if use examples; then
+ find examples/ -name 'Makefile*' -delete || die "Could not rm examples"
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}