summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2018-02-11 21:27:17 -0500
committerChris Reffett <creffett@gentoo.org>2018-02-11 21:27:57 -0500
commitb03cc15b3ecb2adfaa8738d482c46f393c3f20ec (patch)
treead26f56e6575a0527dae646310d9c4fb3ae59b48 /net-libs/libosmocore/libosmocore-0.10.2.ebuild
parentapp-emulation/virt-manager: version bump to 1.5.0 (diff)
downloadgentoo-b03cc15b3ecb2adfaa8738d482c46f393c3f20ec.tar.gz
gentoo-b03cc15b3ecb2adfaa8738d482c46f393c3f20ec.tar.bz2
gentoo-b03cc15b3ecb2adfaa8738d482c46f393c3f20ec.zip
net-libs/libosmocore: Version + EAPI bump
Bug: https://bugs.gentoo.org/608896 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-libs/libosmocore/libosmocore-0.10.2.ebuild')
-rw-r--r--net-libs/libosmocore/libosmocore-0.10.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-libs/libosmocore/libosmocore-0.10.2.ebuild b/net-libs/libosmocore/libosmocore-0.10.2.ebuild
new file mode 100644
index 000000000000..fbd3f9ee9b99
--- /dev/null
+++ b/net-libs/libosmocore/libosmocore-0.10.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
+HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
+ KEYWORDS=""
+else
+ SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2 LGPL-3"
+SLOT="0"
+IUSE="pcsc-lite"
+
+RDEPEND="
+ sys-libs/talloc
+ pcsc-lite? ( sys-apps/pcsc-lite )
+"
+
+DEPEND="${RDEPEND}
+ app-doc/doxygen
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.6.0-automake-1.13.patch" )
+
+src_prepare() {
+ default_src_prepare
+ # set correct version in pkgconfig files
+ sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable pcsc-lite pcsc)
+}