summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-03 14:43:08 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-03 14:43:44 +0200
commit2cdf6527182ffa50c4376c3f4f73fc01cb8f091a (patch)
tree39e887fb569393ef06b4252fed8fe5c80dbd1603 /net-libs/libquotient
parentdev-qt/qtwayland: More fine-grained subslot (diff)
downloadgentoo-2cdf6527182ffa50c4376c3f4f73fc01cb8f091a.tar.gz
gentoo-2cdf6527182ffa50c4376c3f4f73fc01cb8f091a.tar.bz2
gentoo-2cdf6527182ffa50c4376c3f4f73fc01cb8f091a.zip
net-libs/libquotient: 0.6.10 version bump
Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libquotient')
-rw-r--r--net-libs/libquotient/Manifest1
-rw-r--r--net-libs/libquotient/libquotient-0.6.10.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libquotient/Manifest b/net-libs/libquotient/Manifest
index ec0748a6bb54..479462f75e8c 100644
--- a/net-libs/libquotient/Manifest
+++ b/net-libs/libquotient/Manifest
@@ -1 +1,2 @@
+DIST libquotient-0.6.10.tar.gz 561503 BLAKE2B ee5f15af16a964a517e9d51befbf79dbaeb433f366cc1c730681f1bf088a53a38a2ccacfcf4f3cc38998b4a15dbb8418d0864da936f00911f0af94f5aadac36f SHA512 3a70f06c6f74d599033a17527e0bd7abd2b52b9425114def3b0630fbf8ff5c22095227856cae7319e2fb6f7025439606cd986183c5d530463c092209b7291f5a
DIST libquotient-0.6.9.tar.gz 561579 BLAKE2B 160bf9d8a49d4d20ec8fa34aa97ea4e4ceb4b124846f7f042b099de37b742ca5dad4fa7ad8966c6b7c478c2eefe823e6da5ea5e45560ff085e6c6d0ece4d8315 SHA512 3b1e36b402dc78f002c764b738b340f000e0ff23e1bbc753d1dc617a585661529b5f17f91e6093d45c14c0826fac86c56f36c3276c5c9712a74d66731204abca
diff --git a/net-libs/libquotient/libquotient-0.6.10.ebuild b/net-libs/libquotient/libquotient-0.6.10.ebuild
new file mode 100644
index 000000000000..f18a7ff72943
--- /dev/null
+++ b/net-libs/libquotient/libquotient-0.6.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Qt5-based SDK to develop applications for Matrix"
+HOMEPAGE="https://github.com/quotient-im/libQuotient"
+SRC_URI="https://github.com/quotient-im/libQuotient/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/libQuotient-${PV}"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ # downstream patches
+ "${FILESDIR}"/${PN}-0.6.3-no-android.patch
+ "${FILESDIR}"/${PN}-0.6.3-no-tests.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DQuotient_INSTALL_TESTS=OFF
+ -DQuotient_ENABLE_E2EE=OFF # TODO: libolm, libqtolm not packaged
+ -DCMAKE_DISABLE_FIND_PACKAGE_Git=ON # no thanks.
+ )
+ cmake_src_configure
+}