summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Calorì <axelgenus@gmail.com>2015-12-15 12:41:48 +0100
committerAlessandro Calorì <axelgenus@gmail.com>2015-12-16 12:10:33 +0100
commita5c83f6a8b13d530f556f48a31853ca533c1ddce (patch)
tree6f7d91317b074358fad7bf9351e11a7bd946a4dc /net-libs/librsync/librsync-2.0.0.ebuild
parentsys-kernel/vanilla-sources: Automated version bump to {4.1.15,4.2.8,4.3.3} - ... (diff)
downloadgentoo-a5c83f6a8b13d530f556f48a31853ca533c1ddce.tar.gz
gentoo-a5c83f6a8b13d530f556f48a31853ca533c1ddce.tar.bz2
gentoo-a5c83f6a8b13d530f556f48a31853ca533c1ddce.zip
net-libs/librsync: version bump to 2.0.0, fix #525396
Diffstat (limited to 'net-libs/librsync/librsync-2.0.0.ebuild')
-rw-r--r--net-libs/librsync/librsync-2.0.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/librsync/librsync-2.0.0.ebuild b/net-libs/librsync/librsync-2.0.0.ebuild
new file mode 100644
index 000000000000..bd51b8fbe2f6
--- /dev/null
+++ b/net-libs/librsync/librsync-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Remote delta-compression library"
+HOMEPAGE="http://librsync.sourcefrog.net/"
+SRC_URI="https://github.com/librsync/librsync/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="dev-libs/popt"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # isprefix_test does not work in portage environment
+ sed -i '169 s/^/#/' CMakeLists.txt || die
+
+ # fix compiling with multilib-strict feature enabled
+ sed -i "242 s/lib/$(get_libdir)/" CMakeLists.txt || die
+
+ cmake-utils_src_prepare
+}