summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libs3
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libs3')
-rw-r--r--net-libs/libs3/Manifest1
-rw-r--r--net-libs/libs3/files/libs3-2.0-build.patch83
-rw-r--r--net-libs/libs3/libs3-2.0-r1.ebuild34
-rw-r--r--net-libs/libs3/metadata.xml7
4 files changed, 125 insertions, 0 deletions
diff --git a/net-libs/libs3/Manifest b/net-libs/libs3/Manifest
new file mode 100644
index 000000000000..d0d5bdff22e0
--- /dev/null
+++ b/net-libs/libs3/Manifest
@@ -0,0 +1 @@
+DIST libs3-2.0.tar.gz 105783 SHA256 c99857bfbcc9ff47742119bc32f391f38a24acf40cf49902ef3b18b1f0e8c16d SHA512 eabbc24f4beaf270e976bb0071fb372c213dfc00051fc3b33e5f64f9b2690765bd7b764162ecb0da09b173635b37b6e3e0a111523850c8aeea8d9b9be9b9c7c9 WHIRLPOOL 78d968f5503f10d8255e7691d438cc36d8c27f3ff3152c776f5c85cf35f70a6afe894324223055da420e6af19a5a9a92c689876c49d131aaf26d636fef065164
diff --git a/net-libs/libs3/files/libs3-2.0-build.patch b/net-libs/libs3/files/libs3-2.0-build.patch
new file mode 100644
index 000000000000..804a0d28332a
--- /dev/null
+++ b/net-libs/libs3/files/libs3-2.0-build.patch
@@ -0,0 +1,83 @@
+ GNUmakefile | 23 ++++++++++++-----------
+ 1 file changed, 12 insertions(+), 11 deletions(-)
+
+diff --git a/GNUmakefile b/GNUmakefile
+index 36398c1..dc24843 100644
+--- a/GNUmakefile
++++ b/GNUmakefile
+@@ -60,7 +60,7 @@ LIBS3_VER := $(LIBS3_VER_MAJOR).$(LIBS3_VER_MINOR)
+ # any value, then verbosity is turned on". So don't define VERBOSE if you
+ # don't want verbosity in the build process.
+ # -----------------------------------------------------------------------------
+-
++VERBOSE = true
+ ifdef VERBOSE
+ VERBOSE = true
+ VERBOSE_ECHO = @ echo
+@@ -125,7 +125,7 @@ ifndef CFLAGS
+ endif
+ endif
+
+-CFLAGS += -Wall -Werror -Wshadow -Wextra -Iinc \
++CFLAGS += -Wall -Wshadow -Wextra -Iinc \
+ $(CURL_CFLAGS) $(LIBXML2_CFLAGS) \
+ -DLIBS3_VER_MAJOR=\"$(LIBS3_VER_MAJOR)\" \
+ -DLIBS3_VER_MINOR=\"$(LIBS3_VER_MINOR)\" \
+@@ -134,7 +134,8 @@ CFLAGS += -Wall -Werror -Wshadow -Wextra -Iinc \
+ -D_ISOC99_SOURCE \
+ -D_POSIX_C_SOURCE=200112L
+
+-LDFLAGS = $(CURL_LIBS) $(LIBXML2_LIBS) -lpthread
++LDFLAGS += -lpthread
++LIBS = $(CURL_LIBS) $(LIBXML2_LIBS)
+
+
+ # --------------------------------------------------------------------------
+@@ -157,11 +158,11 @@ exported: libs3 s3 headers
+ .PHONY: install
+ install: exported
+ $(QUIET_ECHO) $(DESTDIR)/bin/s3: Installing executable
+- $(VERBOSE_SHOW) install -Dps -m u+rwx,go+rx $(BUILD)/bin/s3 \
++ $(VERBOSE_SHOW) install -Dp -m u+rwx,go+rx $(BUILD)/bin/s3 \
+ $(DESTDIR)/bin/s3
+ $(QUIET_ECHO) \
+ $(DESTDIR)/lib/libs3.so.$(LIBS3_VER): Installing shared library
+- $(VERBOSE_SHOW) install -Dps -m u+rw,go+r \
++ $(VERBOSE_SHOW) install -Dp -m u+rw,go+r \
+ $(BUILD)/lib/libs3.so.$(LIBS3_VER_MAJOR) \
+ $(DESTDIR)/lib/libs3.so.$(LIBS3_VER)
+ $(QUIET_ECHO) \
+@@ -199,18 +200,18 @@ uninstall:
+ $(BUILD)/obj/%.o: src/%.c
+ $(QUIET_ECHO) $@: Compiling object
+ @ mkdir -p $(dir $(BUILD)/dep/$<)
+- @ gcc $(CFLAGS) -M -MG -MQ $@ -DCOMPILINGDEPENDENCIES \
++ $(CC) $(CFLAGS) -M -MG -MQ $@ -DCOMPILINGDEPENDENCIES \
+ -o $(BUILD)/dep/$(<:%.c=%.d) -c $<
+ @ mkdir -p $(dir $@)
+- $(VERBOSE_SHOW) gcc $(CFLAGS) -o $@ -c $<
++ $(VERBOSE_SHOW) $(CC) $(CFLAGS) -o $@ -c $<
+
+ $(BUILD)/obj/%.do: src/%.c
+ $(QUIET_ECHO) $@: Compiling dynamic object
+ @ mkdir -p $(dir $(BUILD)/dep/$<)
+- @ gcc $(CFLAGS) -M -MG -MQ $@ -DCOMPILINGDEPENDENCIES \
++ $(CC) $(CFLAGS) -M -MG -MQ $@ -DCOMPILINGDEPENDENCIES \
+ -o $(BUILD)/dep/$(<:%.c=%.dd) -c $<
+ @ mkdir -p $(dir $@)
+- $(VERBOSE_SHOW) gcc $(CFLAGS) -fpic -fPIC -o $@ -c $<
++ $(VERBOSE_SHOW) $(CC) $(CFLAGS) -fpic -fPIC -o $@ -c $<
+
+
+ # --------------------------------------------------------------------------
+@@ -230,8 +231,8 @@ LIBS3_SOURCES := acl.c bucket.c error_parser.c general.c \
+ $(LIBS3_SHARED): $(LIBS3_SOURCES:%.c=$(BUILD)/obj/%.do)
+ $(QUIET_ECHO) $@: Building shared library
+ @ mkdir -p $(dir $@)
+- $(VERBOSE_SHOW) gcc -shared -Wl,-soname,libs3.so.$(LIBS3_VER_MAJOR) \
+- -o $@ $^ $(LDFLAGS)
++ $(VERBOSE_SHOW) $(CC) $(LDFLAGS) -shared -Wl,-soname,libs3.so.$(LIBS3_VER_MAJOR) \
++ -o $@ $^ $(LIBS)
+
+ $(LIBS3_STATIC): $(LIBS3_SOURCES:%.c=$(BUILD)/obj/%.o)
+ $(QUIET_ECHO) $@: Building static library
diff --git a/net-libs/libs3/libs3-2.0-r1.ebuild b/net-libs/libs3/libs3-2.0-r1.ebuild
new file mode 100644
index 000000000000..5c4023f3aa42
--- /dev/null
+++ b/net-libs/libs3/libs3-2.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A C Library API for Amazon S3"
+HOMEPAGE="http://libs3.ischo.com.s3.amazonaws.com/index.html"
+SRC_URI="http://libs3.ischo.com.s3.amazonaws.com/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="
+ net-misc/curl
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ sed \
+ -e "s:/lib/:/$(get_libdir)/:g" \
+ -i *makefile* || die
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${ED}/usr" install
+ use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*a
+}
diff --git a/net-libs/libs3/metadata.xml b/net-libs/libs3/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/net-libs/libs3/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>