summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 18:26:28 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:34:08 +0100
commit8375ad1370801460f5b535498b829206cb9457a2 (patch)
treeb75fa6c3ca6281bd66b326623aa5ab74c0d8d992 /net-libs/libsearpc/libsearpc-3.2.0-r1.ebuild
parentnet-irc/irker: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-8375ad1370801460f5b535498b829206cb9457a2.tar.gz
gentoo-8375ad1370801460f5b535498b829206cb9457a2.tar.bz2
gentoo-8375ad1370801460f5b535498b829206cb9457a2.zip
net-libs/libsearpc: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/libsearpc/libsearpc-3.2.0-r1.ebuild')
-rw-r--r--net-libs/libsearpc/libsearpc-3.2.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libsearpc/libsearpc-3.2.0-r1.ebuild b/net-libs/libsearpc/libsearpc-3.2.0-r1.ebuild
new file mode 100644
index 000000000000..5ae50cbad5a9
--- /dev/null
+++ b/net-libs/libsearpc/libsearpc-3.2.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python{2_7,3_6})
+
+WANT_AUTOMAKE=1.16
+
+inherit autotools python-single-r1
+
+DESCRIPTION="A simple C language RPC framework"
+HOMEPAGE="https://github.com/haiwen/libsearpc/ http://seafile.com/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.0
+ >=dev-libs/jansson-2.2.1"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/simplejson[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+src_prepare() {
+ default
+ sed -i -e "s/(DESTDIR)//" ${PN}.pc.in || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files, as recommended by ltprune.eclass
+ find "${ED}" -name '*.la' -delete || die
+}