summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMoritz Schlarb <moschlar@metalabs.de>2017-11-03 10:10:18 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-11-15 23:13:27 +0100
commit87f2970ef2080143697d49e40d7c5933e3ae18ab (patch)
tree23f13a539f4dd02058116f25236d02889144d04e /net-libs/libsearpc
parentdev-util/rebar: drop to maintainer-needed. (diff)
downloadgentoo-87f2970ef2080143697d49e40d7c5933e3ae18ab.tar.gz
gentoo-87f2970ef2080143697d49e40d7c5933e3ae18ab.tar.bz2
gentoo-87f2970ef2080143697d49e40d7c5933e3ae18ab.zip
net-libs/libsearpc: installation improvements.
- Remove unnecessary .la file - Fix shebang in searpc-codegen.py Closes: https://github.com/gentoo/gentoo/pull/6005
Diffstat (limited to 'net-libs/libsearpc')
-rw-r--r--net-libs/libsearpc/libsearpc-3.0.8-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/libsearpc/libsearpc-3.0.8-r2.ebuild b/net-libs/libsearpc/libsearpc-3.0.8-r2.ebuild
new file mode 100644
index 000000000000..2b27645bfc81
--- /dev/null
+++ b/net-libs/libsearpc/libsearpc-3.0.8-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+inherit autotools python-single-r1 vcs-snapshot
+
+DESCRIPTION="A simple C language RPC framework"
+HOMEPAGE="https://github.com/haiwen/libsearpc/ http://seafile.com/"
+SRC_URI="https://github.com/haiwen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.26.0
+ >=dev-libs/jansson-2.2.1"
+RDEPEND="${DEPEND}
+ dev-python/simplejson[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+ sed -i -e "s/(DESTDIR)//" ${PN}.pc.in || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ # Remove unnecessary .la files, as recommended by ltprune.eclass
+ find "${ED}" -name '*.la' -delete || die
+ python_fix_shebang "${ED}"usr/bin
+}