summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-09-06 18:14:31 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-09-06 18:45:40 +0200
commit32351dfc706cec2cad86848e360e8b481b5a1db0 (patch)
tree2b4e41a955ab52d7985fc1a2595486dd489046fc /net-libs/libsignon-glib
parentdev-libs/kdiagram: Drop 2.6.3 (diff)
downloadgentoo-32351dfc706cec2cad86848e360e8b481b5a1db0.tar.gz
gentoo-32351dfc706cec2cad86848e360e8b481b5a1db0.tar.bz2
gentoo-32351dfc706cec2cad86848e360e8b481b5a1db0.zip
net-libs/libsignon-glib: Add vala BDEPENDs, py38/9, drop vcs-snapshot
Closes: https://bugs.gentoo.org/740716 Package-Manager: Portage-3.0.5, Repoman-3.0.1 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libsignon-glib')
-rw-r--r--net-libs/libsignon-glib/libsignon-glib-2.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-libs/libsignon-glib/libsignon-glib-2.1.ebuild b/net-libs/libsignon-glib/libsignon-glib-2.1.ebuild
index a07adeedb261..33de3ed28b3b 100644
--- a/net-libs/libsignon-glib/libsignon-glib-2.1.ebuild
+++ b/net-libs/libsignon-glib/libsignon-glib-2.1.ebuild
@@ -3,8 +3,8 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-inherit meson python-r1 vala vcs-snapshot
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit meson python-r1 vala
DESCRIPTION="GLib binding for the D-Bus API provided by signond"
HOMEPAGE="https://01.org/gsso/"
@@ -27,7 +27,7 @@ RDEPEND="
)
"
DEPEND="${RDEPEND}"
-BDEPEND="
+BDEPEND="$(vala_depend)
dev-util/gdbus-codegen
dev-util/glib-utils
doc? ( dev-util/gtk-doc )
@@ -37,9 +37,10 @@ BDEPEND="
# needs more love
RESTRICT="test"
+S="${WORKDIR}/${PN}-VERSION_${PV}"
+
src_prepare() {
default
-
vala_src_prepare
use doc || sed -e "/^subdir('docs')$/d" -i meson.build || die
@@ -87,6 +88,7 @@ src_install() {
if use python; then
python_foreach_impl run_in_build_dir meson_src_install
+ python_foreach_impl python_optimize
else
meson_src_install
fi