summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCristian Othón Martínez Vera <cfuga@cfuga.mx>2022-06-27 14:23:26 -0500
committerSam James <sam@gentoo.org>2022-06-28 00:03:08 +0100
commit3feebf96ee8ee9375f291bf2d9c128c1fa758052 (patch)
tree1a33a47a74f804e6f0888bcb9900e51f5c8b85b8 /net-libs/libssh/libssh-9999.ebuild
parentnet-misc/gallery-dl: bump to 1.22.2 (diff)
downloadgentoo-3feebf96ee8ee9375f291bf2d9c128c1fa758052.tar.gz
gentoo-3feebf96ee8ee9375f291bf2d9c128c1fa758052.tar.bz2
gentoo-3feebf96ee8ee9375f291bf2d9c128c1fa758052.zip
net-libs/libssh: fix musl build with USE="test"
* add sys-libs/argp-standalone as dependency * force cmake to lookup for the argp library Signed-off-by: Cristian Othón Martínez Vera <cfuga@cfuga.mx> Bug: https://bugs.gentoo.org/836705 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libssh/libssh-9999.ebuild')
-rw-r--r--net-libs/libssh/libssh-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-libs/libssh/libssh-9999.ebuild b/net-libs/libssh/libssh-9999.ebuild
index 2801869f419f..7b1299b71476 100644
--- a/net-libs/libssh/libssh-9999.ebuild
+++ b/net-libs/libssh/libssh-9999.ebuild
@@ -14,7 +14,7 @@ if [[ "${PV}" == *9999 ]] ; then
EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
else
SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="LGPL-2.1"
@@ -39,7 +39,9 @@ RDEPEND="
zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
- test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
+ test? (
+ >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}]
+ elibc_musl? ( sys-libs/argp-standalone ) )
"
DOCS=( AUTHORS README ChangeLog )
@@ -66,6 +68,11 @@ src_prepare() {
sed -e "/^check_include_file.*HAVE_VALGRIND_VALGRIND_H/s/^/#DONT /" \
-i ConfigureChecks.cmake || die
+
+ if use test && use elibc_musl; then
+ sed -e "/SOLARIS/d" \
+ -i tests/CMakeLists.txt || die
+ fi
}
multilib_src_configure() {