summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-27 18:35:04 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-27 22:27:52 +0200
commit354f82013dd455c6629fa35b1193464f45afeffb (patch)
tree9beb54dcd019b7fc536dff6363d877cdc1c4a610 /net-libs/libssh2/libssh2-1.8.0-r2.ebuild
parentnet-libs/libwebsockets: [QA] Fix USE=libressl semantics (diff)
downloadgentoo-354f82013dd455c6629fa35b1193464f45afeffb.tar.gz
gentoo-354f82013dd455c6629fa35b1193464f45afeffb.tar.bz2
gentoo-354f82013dd455c6629fa35b1193464f45afeffb.zip
net-libs/libssh2: [QA] Fix USE=libressl semantics
Closes: https://bugs.gentoo.org/684000 Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/libssh2/libssh2-1.8.0-r2.ebuild')
-rw-r--r--net-libs/libssh2/libssh2-1.8.0-r2.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/net-libs/libssh2/libssh2-1.8.0-r2.ebuild b/net-libs/libssh2/libssh2-1.8.0-r2.ebuild
index bdab253bbeed..7eb5156df2c0 100644
--- a/net-libs/libssh2/libssh2-1.8.0-r2.ebuild
+++ b/net-libs/libssh2/libssh2-1.8.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,16 +12,18 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
IUSE="gcrypt libressl mbedtls zlib"
-REQUIRED_USE="
- ?? ( gcrypt libressl mbedtls )
-"
+REQUIRED_USE="?? ( gcrypt mbedtls )"
RESTRICT="test"
RDEPEND="
- !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
- libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
- mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
+ !gcrypt? (
+ mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
+ !mbedtls? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:0=[${MULTILIB_USEDEP}] )
+ )
+ )
zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
"
DEPEND="