summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-04 23:56:51 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-05 00:00:49 +0200
commit85b0e294af7943ec6bc8e0d6e13162bc98ccf23e (patch)
tree5354de300895f9802ec04931a39539f6bd0dd4c8 /net-libs/libssh
parentkde-frameworks: 5.85.0* EAPI-8 bump (diff)
downloadgentoo-85b0e294af7943ec6bc8e0d6e13162bc98ccf23e.tar.gz
gentoo-85b0e294af7943ec6bc8e0d6e13162bc98ccf23e.tar.bz2
gentoo-85b0e294af7943ec6bc8e0d6e13162bc98ccf23e.zip
net-libs/libssh: Cleanup vulnerable 0.9.5
Bug: https://bugs.gentoo.org/810517 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/libssh')
-rw-r--r--net-libs/libssh/Manifest1
-rw-r--r--net-libs/libssh/libssh-0.9.5.ebuild118
2 files changed, 0 insertions, 119 deletions
diff --git a/net-libs/libssh/Manifest b/net-libs/libssh/Manifest
index 6639cb4ed9da..5e3e1048991f 100644
--- a/net-libs/libssh/Manifest
+++ b/net-libs/libssh/Manifest
@@ -1,2 +1 @@
-DIST libssh-0.9.5.tar.xz 502876 BLAKE2B 8ea07bf25218563cbbdab31683e679f71298e2c7c9bb2430195e84892838cd55b9025ed292de65c4942ecec7d4037d5b92a414232fca6c8e41821776f4cf815c SHA512 64e692a0bfa7f73585ea7b7b8b1d4c9a7f9be59565bfd4de32ca8cd9db121f87e7ad51f5c80269fbd99545af34dcf1894374ed8a6d6c1ac5f8601c026572ac18
DIST libssh-0.9.6.tar.xz 1053056 BLAKE2B e8565279a430786b8877386a26700a39386e908546a209815b135a2bf4ef42c37b9890dc29cda9ce6c8bfe3f3bae4942097dc794302aec767d106a45c44b811d SHA512 4040ec4af937e95be2e41313ef6d4db60b46b8d4dea10c09402398127c1d1ca8843392d207088aeee3c7ef631c6ae7b66861327dcebf78ed3af0723777619fd1
diff --git a/net-libs/libssh/libssh-0.9.5.ebuild b/net-libs/libssh/libssh-0.9.5.ebuild
deleted file mode 100644
index 627887023589..000000000000
--- a/net-libs/libssh/libssh-0.9.5.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-CMAKE_ECLASS=cmake
-inherit cmake-multilib
-
-DESCRIPTION="Access a working SSH implementation by means of a library"
-HOMEPAGE="https://www.libssh.org/"
-
-if [[ "${PV}" == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
-else
- SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="LGPL-2.1"
-SLOT="0/4" # subslot = soname major version
-IUSE="debug doc examples gcrypt gssapi mbedtls pcap server +sftp static-libs test zlib"
-# Maintainer: check IUSE-defaults at DefineOptions.cmake
-
-REQUIRED_USE="?? ( gcrypt mbedtls )"
-
-BDEPEND="
- doc? ( app-doc/doxygen[dot] )
-"
-RDEPEND="
- !gcrypt? (
- !mbedtls? (
- >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}]
- )
- )
- gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
- gssapi? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
- mbedtls? ( net-libs/mbedtls:=[${MULTILIB_USEDEP}] )
- zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
-"
-DEPEND="${RDEPEND}
- test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
-"
-
-DOCS=( AUTHORS README ChangeLog )
-
-PATCHES=( "${FILESDIR}/${PN}-0.8.0-tests.patch" )
-
-RESTRICT+=" !test? ( test )"
-
-src_prepare() {
- cmake_src_prepare
-
- # just install the examples, do not compile them
- cmake_comment_add_subdirectory examples
-
- # keyfile torture test is currently broken
- sed -e "/torture_keyfiles/d" \
- -i tests/unittests/CMakeLists.txt || die
-
- # disable tests that take too long (bug #677006)
- if use sparc; then
- sed -e "/torture_threads_pki_rsa/d" -e "/torture_pki_dsa/d" \
- -i tests/unittests/CMakeLists.txt || die
- fi
-
- sed -e "/^check_include_file.*HAVE_VALGRIND_VALGRIND_H/s/^/#DONT /" \
- -i ConfigureChecks.cmake || die
-}
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DWITH_NACL=OFF
- -DWITH_STACK_PROTECTOR=OFF
- -DWITH_STACK_PROTECTOR_STRONG=OFF
- -DWITH_DEBUG_CALLTRACE="$(usex debug)"
- -DWITH_DEBUG_CRYPTO="$(usex debug)"
- -DWITH_GCRYPT="$(usex gcrypt)"
- -DWITH_GSSAPI="$(usex gssapi)"
- -DWITH_MBEDTLS="$(usex mbedtls)"
- -DWITH_PCAP="$(usex pcap)"
- -DWITH_SERVER="$(usex server)"
- -DWITH_SFTP="$(usex sftp)"
- -DBUILD_STATIC_LIB="$(usex static-libs)"
- -DUNIT_TESTING="$(usex test)"
- -DWITH_ZLIB="$(usex zlib)"
- )
-
- multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
-
- cmake_src_configure
-}
-
-multilib_src_compile() {
- cmake_src_compile
- multilib_is_native_abi && use doc && cmake_src_compile docs
-}
-
-multilib_src_install() {
- cmake_src_install
- multilib_is_native_abi && use doc && HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
-
- use static-libs && dolib.a src/libssh.a
-
- # compatibility symlink until all consumers have been updated
- # to no longer use libssh_threads.so
- dosym libssh.so /usr/$(get_libdir)/libssh_threads.so
-}
-
-multilib_src_install_all() {
- use mbedtls && DOCS+=( README.mbedtls )
- einstalldocs
-
- if use examples; then
- docinto examples
- dodoc examples/*.{c,h,cpp}
- fi
-}