summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-10-02 15:32:01 +0200
committerJeroen Roovers <jer@gentoo.org>2018-10-02 15:33:04 +0200
commitc191801ff491f6e9058e7c2fc511c9672b04f1dc (patch)
tree618b1259567ac1b83ff1bcf0d8a4d7e5a59751ad /net-libs/libssh
parentmedia-sound/lollypop: New package (diff)
downloadgentoo-c191801ff491f6e9058e7c2fc511c9672b04f1dc.tar.gz
gentoo-c191801ff491f6e9058e7c2fc511c9672b04f1dc.tar.bz2
gentoo-c191801ff491f6e9058e7c2fc511c9672b04f1dc.zip
net-libs/libssh: Fix compile error on HPPA
Package-Manager: Portage-2.3.50, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/libssh')
-rw-r--r--net-libs/libssh/files/libssh-0.8.3-strict-overflow.patch21
-rw-r--r--net-libs/libssh/libssh-0.8.3-r1.ebuild111
2 files changed, 132 insertions, 0 deletions
diff --git a/net-libs/libssh/files/libssh-0.8.3-strict-overflow.patch b/net-libs/libssh/files/libssh-0.8.3-strict-overflow.patch
new file mode 100644
index 000000000000..93b15ec061b8
--- /dev/null
+++ b/net-libs/libssh/files/libssh-0.8.3-strict-overflow.patch
@@ -0,0 +1,21 @@
+Neither i nor j are ever counted downward for the array pointers, so assume
+they were intended to be signed integers.
+
+Fixes a compiler warning on HPPA triggering an error because of
+-Werror=strict-overflow -Wstrict-overflow=2:
+
+src/connect.c:509:7: error: assuming signed overflow does not occur when
+simplifying conditional to constant [-Werror=strict-overflow]
+ if(j != 0)
+ ^
+--- a/src/connect.c
++++ b/src/connect.c
+@@ -471,7 +471,7 @@
+ fd_set *readfds, struct timeval *timeout) {
+ fd_set origfds;
+ socket_t fd;
+- int i,j;
++ unsigned int i,j;
+ int rc;
+ int base_tm, tm;
+ struct ssh_timestamp ts;
diff --git a/net-libs/libssh/libssh-0.8.3-r1.ebuild b/net-libs/libssh/libssh-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..7b660604f3aa
--- /dev/null
+++ b/net-libs/libssh/libssh-0.8.3-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${PN}-${PV/_rc/rc}"
+inherit cmake-multilib
+
+DESCRIPTION="Access a working SSH implementation by means of a library"
+HOMEPAGE="https://www.libssh.org/"
+
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.libssh.org/projects/libssh.git"
+else
+ inherit eapi7-ver
+ SRC_URI="https://www.libssh.org/files/$(ver_cut 1-2)/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0/4" # subslot = soname major version
+IUSE="debug doc examples gcrypt gssapi libressl mbedtls pcap server +sftp static-libs test zlib"
+# Maintainer: check IUSE-defaults at DefineOptions.cmake
+
+REQUIRED_USE="?? ( gcrypt mbedtls ) test? ( static-libs )"
+
+RDEPEND="
+ !gcrypt? (
+ !mbedtls? (
+ !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0=[${MULTILIB_USEDEP}] )
+ libressl? ( dev-libs/libressl:=[${MULTILIB_USEDEP}] )
+ )
+ )
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0[${MULTILIB_USEDEP}] )
+ gssapi? ( >=virtual/krb5-0-r1[${MULTILIB_USEDEP}] )
+ mbedtls? ( net-libs/mbedtls[${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[dot] )
+ test? ( >=dev-util/cmocka-0.3.1[${MULTILIB_USEDEP}] )
+"
+
+DOCS=( AUTHORS README ChangeLog )
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.8.0-tests.patch"
+ "${FILESDIR}/${PN}-0.8.3-strict-overflow.patch"
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # just install the examples, do not compile them
+ cmake_comment_add_subdirectory examples
+
+ # keyfile torture test is currently broken
+ sed -i \
+ -e '/torture_keyfiles/d' \
+ tests/unittests/CMakeLists.txt || die
+}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUNIT_TESTING="$(usex test)"
+ -DWITH_DEBUG_CALLTRACE="$(usex debug)"
+ -DWITH_DEBUG_CRYPTO="$(usex debug)"
+ -DWITH_GCRYPT="$(usex gcrypt)"
+ -DWITH_GSSAPI="$(usex gssapi)"
+ -DWITH_MBEDTLS="$(usex mbedtls)"
+ -DWITH_NACL=no
+ -DWITH_PCAP="$(usex pcap)"
+ -DWITH_SERVER="$(usex server)"
+ -DWITH_SFTP="$(usex sftp)"
+ -DWITH_STACK_PROTECTOR=OFF
+ -DWITH_STACK_PROTECTOR_STRONG=OFF
+ -DWITH_STATIC_LIB="$(usex static-libs)"
+ -DWITH_ZLIB="$(usex zlib)"
+ )
+
+ multilib_is_native_abi || mycmakeargs+=( -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=ON )
+
+ cmake-utils_src_configure
+}
+
+multilib_src_compile() {
+ cmake-utils_src_compile
+ multilib_is_native_abi && use doc && cmake-utils_src_compile docs
+}
+
+multilib_src_install() {
+ cmake-utils_src_install
+ use doc && HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
+
+ # compatibility symlink until all consumers have been updated
+ # to no longer use libssh_threads.so
+ dosym libssh.so /usr/$(get_libdir)/libssh_threads.so
+}
+
+multilib_src_install_all() {
+ use mbedtls && DOCS+=( README.mbedtls )
+ einstalldocs
+
+ if use examples; then
+ docinto examples
+ dodoc examples/*.{c,h,cpp}
+ fi
+}