summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-06-16 19:25:13 +0200
committerDavid Seifert <soap@gentoo.org>2019-06-16 19:25:13 +0200
commitc8ed5a100d1aaec0a80dbfb360412a042d161792 (patch)
tree904401e62f59ab90d4ebb208b5905d4fbdce06d2 /net-libs/libtelnet
parentdev-lisp/clisp-2.49.92-r0: alpha stable (diff)
downloadgentoo-c8ed5a100d1aaec0a80dbfb360412a042d161792.tar.gz
gentoo-c8ed5a100d1aaec0a80dbfb360412a042d161792.tar.bz2
gentoo-c8ed5a100d1aaec0a80dbfb360412a042d161792.zip
net-libs/libtelnet: Update live ebuild
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-libs/libtelnet')
-rw-r--r--net-libs/libtelnet/libtelnet-9999.ebuild35
1 files changed, 13 insertions, 22 deletions
diff --git a/net-libs/libtelnet/libtelnet-9999.ebuild b/net-libs/libtelnet/libtelnet-9999.ebuild
index aae3c462a1cc..620355b68c92 100644
--- a/net-libs/libtelnet/libtelnet-9999.ebuild
+++ b/net-libs/libtelnet/libtelnet-9999.ebuild
@@ -1,33 +1,24 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils autotools
-DESCRIPTION="Simple RFC-complient TELNET implementation as a C library"
-HOMEPAGE="https://github.com/seanmiddleditch/libtelnet"
+EAPI=7
+
+inherit cmake-utils
-if [ ${PV} = 9999 ]; then
- KEYWORDS=""
- EGIT_REPO_URI="https://github.com/seanmiddleditch/${PN}.git"
- inherit git-2
- DEPEND="dev-vcs/git"
- S="${WORKDIR}/${PN}-master"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/seanmiddleditch/libtelnet.git"
else
+ SRC_URI="https://github.com/seanmiddleditch/libtelnet/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~x86 ~amd64"
- SRC_URI="https://github.com/seanmiddleditch/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
-WANT_AUTOMAKE=1.11
-DEPEND="${DEPEND} sys-devel/automake:${WANT_AUTOMAKE}"
+DESCRIPTION="Simple RFC-complient TELNET implementation as a C library"
+HOMEPAGE="https://github.com/seanmiddleditch/libtelnet"
+
LICENSE="public-domain"
SLOT="0"
IUSE=""
-RDEPEND=""
-src_prepare() {
- _elibtoolize
- eaclocal
- eautoconf
- eautoheader
- eautomake
-}
+# needed unconditionally for man pages
+DEPEND="app-doc/doxygen"