summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-27 01:32:44 +0100
committerSam James <sam@gentoo.org>2021-08-27 01:33:12 +0100
commitac3234e6bb0e647c0bbdb98fd36c2aeb5d5b396d (patch)
tree305413c788f7bc944ffaf42e563b0336e0cbf4f4 /net-libs/libtorrent-rasterbar
parentnet-libs/libtorrent-rasterbar: post-merge minor cleanup (diff)
downloadgentoo-ac3234e6bb0e647c0bbdb98fd36c2aeb5d5b396d.tar.gz
gentoo-ac3234e6bb0e647c0bbdb98fd36c2aeb5d5b396d.tar.bz2
gentoo-ac3234e6bb0e647c0bbdb98fd36c2aeb5d5b396d.zip
net-libs/libtorrent-rasterbar: fix Boost 1.77 compatibility
Revbumping because the patch seems a bit invasive and also to fix DEPEND. Closes: https://bugs.gentoo.org/808084 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/libtorrent-rasterbar')
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.77.patch37
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r1.ebuild (renamed from net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4.ebuild)6
2 files changed, 42 insertions, 1 deletions
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.77.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.77.patch
new file mode 100644
index 000000000000..b39f62614b2a
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-2.0.4-boost-1.77.patch
@@ -0,0 +1,37 @@
+https://github.com/arvidn/libtorrent/pull/6412
+https://github.com/arvidn/libtorrent/issues/6405
+https://bugs.gentoo.org/808084
+
+From 906cedddedbdf9d98ecf2bd19340f7f17869b968 Mon Sep 17 00:00:00 2001
+From: arvidn <arvid@libtorrent.org>
+Date: Thu, 19 Aug 2021 11:54:13 +0200
+Subject: [PATCH] bump handler allocation sizes for boost-1.77 (linux)
+
+---
+ include/libtorrent/aux_/allocating_handler.hpp | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/include/libtorrent/aux_/allocating_handler.hpp b/include/libtorrent/aux_/allocating_handler.hpp
+index 9d826d11a1..b24349850e 100644
+--- a/include/libtorrent/aux_/allocating_handler.hpp
++++ b/include/libtorrent/aux_/allocating_handler.hpp
+@@ -122,14 +122,14 @@ namespace libtorrent { namespace aux {
+ constexpr std::size_t fuzzer_write_cost = 0;
+ constexpr std::size_t fuzzer_read_cost = 0;
+ #endif
+- constexpr std::size_t write_handler_max_size = tracking + debug_write_iter + openssl_write_cost + fuzzer_write_cost + 152;
+- constexpr std::size_t read_handler_max_size = tracking + debug_read_iter + openssl_read_cost + fuzzer_read_cost + 152;
+- constexpr std::size_t udp_handler_max_size = tracking + 144;
+- constexpr std::size_t utp_handler_max_size = tracking + 168;
++ constexpr std::size_t write_handler_max_size = tracking + debug_write_iter + openssl_write_cost + fuzzer_write_cost + 168;
++ constexpr std::size_t read_handler_max_size = tracking + debug_read_iter + openssl_read_cost + fuzzer_read_cost + 168;
++ constexpr std::size_t udp_handler_max_size = tracking + 160;
++ constexpr std::size_t utp_handler_max_size = tracking + 184;
+ constexpr std::size_t abort_handler_max_size = tracking + 72;
+ constexpr std::size_t submit_handler_max_size = tracking + 72;
+ constexpr std::size_t deferred_handler_max_size = tracking + 80;
+- constexpr std::size_t tick_handler_max_size = tracking + 112;
++ constexpr std::size_t tick_handler_max_size = tracking + 128;
+ #endif
+
+ enum HandlerName
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r1.ebuild
index 739fc3f8e91f..127f26feb7fe 100644
--- a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4.ebuild
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-2.0.4-r1.ebuild
@@ -19,6 +19,7 @@ IUSE="+dht debug gnutls python ssl test"
RESTRICT="!test? ( test ) test" # not yet fixed
RDEPEND="dev-libs/boost:=[threads(+)]"
DEPEND="
+ ${RDEPEND}
python? (
${PYTHON_DEPS}
$(python_gen_any_dep '
@@ -28,9 +29,12 @@ DEPEND="
gnutls? ( net-libs/gnutls:= )
!gnutls? ( dev-libs/openssl:= )
)
- ${DEPEND}
"
+PATCHES=(
+ "${FILESDIR}"/${P}-boost-1.77.patch
+)
+
pkg_setup() {
use python && python-any-r1_pkg_setup
}