summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel M. Weeks <dan@danweeks.net>2021-03-06 09:37:19 -0500
committerJoonas Niilola <juippis@gentoo.org>2021-03-16 15:01:31 +0200
commit40c1c520fd19dd23fbc0bbfd31a536ea5c676d01 (patch)
treeb42a7c38c57c814739a00d74400ac34278d5e6a6 /net-libs/libtorrent
parentnet-libs/libsrtp-1.6.0-r1: Fix compilation with sys-devel/autoconf-2.71 (diff)
downloadgentoo-40c1c520fd19dd23fbc0bbfd31a536ea5c676d01.tar.gz
gentoo-40c1c520fd19dd23fbc0bbfd31a536ea5c676d01.tar.bz2
gentoo-40c1c520fd19dd23fbc0bbfd31a536ea5c676d01.zip
net-libs/libtorrent: cppunit to RDEPEND, add subslot
Closes: https://bugs.gentoo.org/773340 Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Daniel M. Weeks <dan@danweeks.net> Closes: https://github.com/gentoo/gentoo/pull/19796 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/libtorrent-0.13.8.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-libs/libtorrent/libtorrent-0.13.8.ebuild b/net-libs/libtorrent/libtorrent-0.13.8.ebuild
index 1e5ec4094bab..44be3294c262 100644
--- a/net-libs/libtorrent/libtorrent-0.13.8.ebuild
+++ b/net-libs/libtorrent/libtorrent-0.13.8.ebuild
@@ -21,16 +21,16 @@ KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86
IUSE="debug libressl ssl test"
RESTRICT="!test? ( test )"
+# cppunit dependency - https://github.com/rakshasa/libtorrent/issues/182
RDEPEND="
+ dev-util/cppunit:=
sys-libs/zlib
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
)"
DEPEND="${RDEPEND}
- virtual/pkgconfig
- dev-util/cppunit"
-# cppunit dependency - https://github.com/rakshasa/libtorrent/issues/182
+ virtual/pkgconfig"
src_configure() {
# bug 518582