summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-29 17:53:51 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-29 20:27:33 -0400
commitbb551090a96ede9f8eab6f91d6f1f22d254bb042 (patch)
tree42a9c3fdcaadb8992b762b4fffa260e8f1989dd8 /net-libs/libyahoo2
parentmedia-video/vobcopy: bump EAPI (diff)
downloadgentoo-bb551090a96ede9f8eab6f91d6f1f22d254bb042.tar.gz
gentoo-bb551090a96ede9f8eab6f91d6f1f22d254bb042.tar.bz2
gentoo-bb551090a96ede9f8eab6f91d6f1f22d254bb042.zip
net-libs/libyahoo2: bump EAPI; drop eutils; add LibreSSL support
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'net-libs/libyahoo2')
-rw-r--r--net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch4
-rw-r--r--net-libs/libyahoo2/libyahoo2-1.0.1.ebuild27
2 files changed, 19 insertions, 12 deletions
diff --git a/net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch b/net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch
index b05190a02a71..4e0f1142cd52 100644
--- a/net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch
+++ b/net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch
@@ -1,5 +1,5 @@
---- src/Makefile.am
-+++ src/Makefile.am
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -21,11 +21,9 @@
noinst_PROGRAMS = yahoo autoresponder
diff --git a/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild b/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild
index 0cd41ed48213..541f05dc3d81 100644
--- a/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild
+++ b/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit autotools eutils
+EAPI=7
+inherit autotools
DESCRIPTION="interface to the new Yahoo! Messenger protocol"
HOMEPAGE="http://libyahoo2.sourceforge.net/"
@@ -11,33 +11,40 @@ SRC_URI="mirror://sourceforge/libyahoo2/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="static-libs ssl"
+IUSE="libressl ssl static-libs"
RDEPEND="dev-libs/glib:2
- ssl? ( dev-libs/openssl )"
+ ssl? (
+ libressl? ( dev-libs/libressl:0= )
+ !libressl? ( dev-libs/openssl:0= )
+ )
+"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${P}-asneeded.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-asneeded.patch
+ default
sed -i -e 's:-ansi -pedantic::' configure.ac || die #240912
eautoreconf
}
src_configure() {
econf \
- --disable-dependency-tracking \
$(use_enable static-libs static) \
$(use_enable ssl sample-client)
}
src_install() {
- emake DESTDIR="${D}" install || die
+ default
if use ssl; then
- dobin src/.libs/{autoresponder,yahoo} || die
+ dobin src/.libs/{autoresponder,yahoo}
fi
dodoc AUTHORS ChangeLog doc/*.txt NEWS README TODO
- find "${D}" -name '*.la' -exec rm -f '{}' +
+ find "${D}" -name '*.la' -delete || die "Pruning failed"
}