summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-09 22:47:25 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-09 23:08:05 +0100
commit2767cc9526713c77edf1b6bcaa660f78722caa79 (patch)
treec7b91ac99280b636ebd58c460b58b971a94eca50 /net-libs/miniupnpc
parentdev-python/boto3: Bump to 1.16.14 (diff)
downloadgentoo-2767cc9526713c77edf1b6bcaa660f78722caa79.tar.gz
gentoo-2767cc9526713c77edf1b6bcaa660f78722caa79.tar.bz2
gentoo-2767cc9526713c77edf1b6bcaa660f78722caa79.zip
net-libs/miniupnpc: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-libs/miniupnpc')
-rw-r--r--net-libs/miniupnpc/Manifest2
-rw-r--r--net-libs/miniupnpc/miniupnpc-2.2.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/net-libs/miniupnpc/Manifest b/net-libs/miniupnpc/Manifest
index be08cc171d73..e8a90f1282f2 100644
--- a/net-libs/miniupnpc/Manifest
+++ b/net-libs/miniupnpc/Manifest
@@ -2,3 +2,5 @@ DIST miniupnpc-2.1.20191224.tar.gz 94740 BLAKE2B 85c0b3eb678685bc7192dbee9440ec5
DIST miniupnpc-2.1.20191224.tar.gz.sig 543 BLAKE2B ddbde04faa7bce62fdbb5b555bda9dc9ff69f09cc97442049adc787a03ec91824f14cdddaef6e577cf8d08fa96202fc792333b8dab7e6e8c30847fa9302a35d0 SHA512 b8885d2002259c95ede7ab57aaf82db83c2bd7ace3d0986179efac4245ffd42161049e0167a9ac1ff18de6c8df4d39356f0fb6aa6dada7523a238b4db4838887
DIST miniupnpc-2.1.20201016.tar.gz 97682 BLAKE2B 2c98f71ff7262a24a69a9a4af411dbeb58c20ec4181bca8bbdd61c628bf5bd49f7e9b763b73ffb5d3508b5b545a0c918828ead2a376b57b8ea5051cd7b8e9c13 SHA512 d619f7e205cac68137020fab31e8bdaeebd09eeaca5e42e1e03a9e0085a64d635ec896862a488b0d57798d1e6ce96e2ba5652f60c0b8df9fc866eea90baea152
DIST miniupnpc-2.1.20201016.tar.gz.sig 543 BLAKE2B b8ddcadb58e7b8dc4646ea1ac4e10331fe70a5b9a27902dd5ad09ac306605160b63f2e21d96eda4aa0f77485800cb9c5aa110f215dbe3536a9f6ec1c4a5e9ed9 SHA512 fb7886d4198bd2ae1eeff293152ff509e7ebe6ff0f9b3c20d5824f7ca9f65091a61db2bc0a8ac9fb0449994aba594cff3bf6c556876dbb47d593ecf8b7b26d10
+DIST miniupnpc-2.2.0.tar.gz 98348 BLAKE2B 3464dc7f0b5416b558d0dd49121f3b851d9808a516c19d4f99fdb205e20149f27ef495d9f8da09ad3a28656580bfc16d1cf99ef993e41e9600cfe427b4a776d2 SHA512 b5bb674f162cae3d9e0205a9cdf6acc1fb334ab8ac5330be924411a8fd46833fb916d09f947d1e40d05224df7df1ecf6d812037185690e5022287c2024eb183f
+DIST miniupnpc-2.2.0.tar.gz.sig 543 BLAKE2B c75dbc54debc77e63ea3534f8f424a3904131893fc31d6485163ee6ecdafdab02fc0db8e290d28c834ac0efc5a37c34cbca7f14e1c78f859d22abc4e0b2ae48f SHA512 54f8cccea5886e06fbdaa04d270c12bd95d219be0b275491d9168f1089b1efe96e8a6f30ebf428091a3bae4bc349c0b8c94a22e94d56845a0a8b9724b1f9f74d
diff --git a/net-libs/miniupnpc/miniupnpc-2.2.0.ebuild b/net-libs/miniupnpc/miniupnpc-2.2.0.ebuild
new file mode 100644
index 000000000000..9e79fd0ac53e
--- /dev/null
+++ b/net-libs/miniupnpc/miniupnpc-2.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs verify-sig
+
+DESCRIPTION="UPnP client library and a simple UPnP client"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz
+ verify-sig? ( http://miniupnp.free.fr/files/${P}.tar.gz.sig )"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="ipv6 kernel_linux static-libs"
+
+RDEPEND=""
+BDEPEND="
+ kernel_linux? ( sys-apps/lsb-release sys-apps/which )
+ verify-sig? ( app-crypt/openpgp-keys-miniupnp )"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/miniupnp.asc
+
+src_prepare() {
+ eapply_user
+
+ # These bins are not installed, upnpc-static requires building static lib
+ sed -i -e '/EXECUTABLES =/s/ upnpc-static listdevices//' Makefile || die
+ # Prevent gzipping manpage.
+ sed -i -e '/gzip/d' Makefile || die
+
+ if ! use static-libs; then
+ sed -i \
+ -e '/FILESTOINSTALL =/s/ $(LIBRARY)//' \
+ -e '/$(INSTALL) -m 644 $(LIBRARY) $(DESTDIR)$(INSTALLDIRLIB)/d' \
+ Makefile || die
+ fi
+}
+
+# Upstream cmake causes more trouble than it fixes,
+# so we'll just stay with the Makefile for now.
+
+src_compile() {
+ tc-export CC AR
+ emake upnpc-shared $(usex static-libs upnpc-static '')
+}
+
+src_test() {
+ emake -j1 HAVE_IPV6=$(usex ipv6) check
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ INSTALLDIRLIB="${EPREFIX}/usr/$(get_libdir)" \
+ install
+
+ dodoc README Changelog.txt
+}