summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-09-20 17:08:56 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-09-20 18:38:04 +0200
commit3655f63ff09bb263294295b742a3ee9dc4719bb0 (patch)
treedfd7397a3b1a684d066fabb2a21b8a2818a3395a /net-libs/nghttp2
parentdev-perl/Net-SSH2: add libressl support (diff)
downloadgentoo-3655f63ff09bb263294295b742a3ee9dc4719bb0.tar.gz
gentoo-3655f63ff09bb263294295b742a3ee9dc4719bb0.tar.bz2
gentoo-3655f63ff09bb263294295b742a3ee9dc4719bb0.zip
net-libs/nghttp2: add libressl support
Diffstat (limited to 'net-libs/nghttp2')
-rw-r--r--net-libs/nghttp2/nghttp2-1.2.1-r1.ebuild62
-rw-r--r--net-libs/nghttp2/nghttp2-9999.ebuild5
2 files changed, 65 insertions, 2 deletions
diff --git a/net-libs/nghttp2/nghttp2-1.2.1-r1.ebuild b/net-libs/nghttp2/nghttp2-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..7ef717f44ed6
--- /dev/null
+++ b/net-libs/nghttp2/nghttp2-1.2.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI="5"
+
+inherit multilib-minimal
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/tatsuhiro-t/nghttp2.git"
+ inherit git-2
+else
+ SRC_URI="https://github.com/tatsuhiro-t/nghttp2/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="HTTP/2 C Library"
+HOMEPAGE="https://nghttp2.org/"
+
+LICENSE="MIT"
+SLOT="0/1.14" # <C++>.<C> SONAMEs
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
+
+RDEPEND="
+ cxx? ( dev-libs/boost[${MULTILIB_USEDEP},threads] )
+ hpack-tools? ( >=dev-libs/jansson-2.5 )
+ jemalloc? ( dev-libs/jemalloc )
+ utils? (
+ >=dev-libs/libev-4.15
+ !libressl? ( >=dev-libs/openssl-1.0.2:0 )
+ libressl? ( dev-libs/libressl )
+ >=sys-libs/zlib-1.2.3
+ )
+ xml? ( >=dev-libs/libxml2-2.7.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ --disable-examples \
+ --disable-failmalloc \
+ --disable-werror \
+ --without-cython \
+ --disable-python-bindings \
+ --without-spdylay \
+ $(use_enable cxx asio-lib) \
+ $(use_enable debug) \
+ $(multilib_native_use_enable hpack-tools) \
+ $(use_enable static-libs static) \
+ $(use_enable threads) \
+ $(multilib_native_use_enable utils app) \
+ $(multilib_native_use_with jemalloc) \
+ $(multilib_native_use_with xml libxml2)
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -name '*.la' -delete
+}
diff --git a/net-libs/nghttp2/nghttp2-9999.ebuild b/net-libs/nghttp2/nghttp2-9999.ebuild
index 3a8f8503cdd2..7ef717f44ed6 100644
--- a/net-libs/nghttp2/nghttp2-9999.ebuild
+++ b/net-libs/nghttp2/nghttp2-9999.ebuild
@@ -21,7 +21,7 @@ HOMEPAGE="https://nghttp2.org/"
LICENSE="MIT"
SLOT="0/1.14" # <C++>.<C> SONAMEs
-IUSE="cxx debug hpack-tools jemalloc static-libs test +threads utils xml"
+IUSE="cxx debug hpack-tools jemalloc libressl static-libs test +threads utils xml"
RDEPEND="
cxx? ( dev-libs/boost[${MULTILIB_USEDEP},threads] )
@@ -29,7 +29,8 @@ RDEPEND="
jemalloc? ( dev-libs/jemalloc )
utils? (
>=dev-libs/libev-4.15
- >=dev-libs/openssl-1.0.2
+ !libressl? ( >=dev-libs/openssl-1.0.2:0 )
+ libressl? ( dev-libs/libressl )
>=sys-libs/zlib-1.2.3
)
xml? ( >=dev-libs/libxml2-2.7.7 )"