summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-04-23 15:20:48 +0200
committerMarek Szuba <marecki@gentoo.org>2021-04-23 15:48:39 +0200
commit5f0fc09e53bfe231a41647ae29fd6bd495c4ed98 (patch)
treeed0c8e1b11ff99d7c6906efeb286f84556606413 /net-libs/nodejs
parentmedia-gfx/pngcrush: Keyword 1.8.13 arm64, #774222 (diff)
downloadgentoo-5f0fc09e53bfe231a41647ae29fd6bd495c4ed98.tar.gz
gentoo-5f0fc09e53bfe231a41647ae29fd6bd495c4ed98.tar.bz2
gentoo-5f0fc09e53bfe231a41647ae29fd6bd495c4ed98.zip
net-libs/nodejs: filter out user-defined LTO flags
Node build scripts insert user-defined compiler/linker flags after the ones they define themselves, meaning that user-defined -flto can override the -fno-lto set for v8_cppgc_shared - triggering build errors. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/nodejs-12.22.1-r1.ebuild5
-rw-r--r--net-libs/nodejs/nodejs-14.16.1-r1.ebuild5
-rw-r--r--net-libs/nodejs/nodejs-16.0.0-r1.ebuild5
3 files changed, 12 insertions, 3 deletions
diff --git a/net-libs/nodejs/nodejs-12.22.1-r1.ebuild b/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
index b9181293ba33..aa8392c1ff25 100644
--- a/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE="threads(+)"
-inherit bash-completion-r1 pax-utils python-any-r1 toolchain-funcs xdg-utils
+inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -105,6 +105,9 @@ src_prepare() {
src_configure() {
xdg_environment_reset
+ # LTO compiler flags are handled by configure.py itself
+ filter-flags '-flto*'
+
local myconf=(
--shared-brotli
--shared-cares
diff --git a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
index 481182d77564..02e8c08318b3 100644
--- a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE="threads(+)"
-inherit bash-completion-r1 pax-utils python-any-r1 toolchain-funcs xdg-utils
+inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -103,6 +103,9 @@ src_prepare() {
src_configure() {
xdg_environment_reset
+ # LTO compiler flags are handled by configure.py itself
+ filter-flags '-flto*'
+
local myconf=(
--shared-brotli
--shared-cares
diff --git a/net-libs/nodejs/nodejs-16.0.0-r1.ebuild b/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
index 612a576994a0..e9e14a673451 100644
--- a/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
+++ b/net-libs/nodejs/nodejs-16.0.0-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE="threads(+)"
-inherit bash-completion-r1 pax-utils python-any-r1 toolchain-funcs xdg-utils
+inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -102,6 +102,9 @@ src_prepare() {
src_configure() {
xdg_environment_reset
+ # LTO compiler flags are handled by configure.py itself
+ filter-flags '-flto*'
+
local myconf=(
--shared-brotli
--shared-cares