summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-11-21 19:39:24 +0100
committerJeroen Roovers <jer@gentoo.org>2017-11-21 19:39:46 +0100
commit68a9362fd26f69996823c36ead90fe053537f1fe (patch)
treeef4d3d60c048a76948d035070238e33d31f02113 /net-libs/nodejs
parentdev-util/docker-distribution-pruner: Unmaintain (diff)
downloadgentoo-68a9362fd26f69996823c36ead90fe053537f1fe.tar.gz
gentoo-68a9362fd26f69996823c36ead90fe053537f1fe.tar.bz2
gentoo-68a9362fd26f69996823c36ead90fe053537f1fe.zip
net-libs/nodejs: Fix USE=-ssl (bug #615448 by Toralf Förster).
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/nodejs-8.9.1.ebuild22
-rw-r--r--net-libs/nodejs/nodejs-9.2.0.ebuild22
2 files changed, 24 insertions, 20 deletions
diff --git a/net-libs/nodejs/nodejs-8.9.1.ebuild b/net-libs/nodejs/nodejs-8.9.1.ebuild
index 38c6428ce065..9cc359cb23f5 100644
--- a/net-libs/nodejs/nodejs-8.9.1.ebuild
+++ b/net-libs/nodejs/nodejs-8.9.1.ebuild
@@ -18,13 +18,15 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
IUSE="cpu_flags_x86_sse2 debug doc icu +npm +snapshot +ssl systemtap test"
-RDEPEND="icu? ( >=dev-libs/icu-56:= )
- npm? ( ${PYTHON_DEPS} )
- >=net-libs/http-parser-2.7.0:=
+RDEPEND="
>=dev-libs/libuv-1.15.0:=
+ >=net-libs/http-parser-2.7.0:=
>=net-libs/nghttp2-1.25.0
- >=dev-libs/openssl-1.0.2g:0=[-bindist]
- sys-libs/zlib"
+ sys-libs/zlib
+ icu? ( >=dev-libs/icu-56:= )
+ npm? ( ${PYTHON_DEPS} )
+ ssl? ( >=dev-libs/openssl-1.0.2g:0=[-bindist] )
+"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
systemtap? ( dev-util/systemtap )
@@ -89,14 +91,14 @@ src_prepare() {
}
src_configure() {
- local myarch=""
- local myconf=( --shared-http-parser --shared-libuv --shared-nghttp2 --shared-openssl --shared-zlib )
- use npm || myconf+=( --without-npm )
+ local myconf=( --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
+ use debug && myconf+=( --debug )
use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
+ use npm || myconf+=( --without-npm )
use snapshot && myconf+=( --with-snapshot )
- use ssl || myconf+=( --without-ssl )
- use debug && myconf+=( --debug )
+ use ssl && myconf+=( --shared-openssl ) || myconf+=( --without-ssl )
+ local myarch=""
case ${ABI} in
amd64) myarch="x64";;
arm) myarch="arm";;
diff --git a/net-libs/nodejs/nodejs-9.2.0.ebuild b/net-libs/nodejs/nodejs-9.2.0.ebuild
index aaab3c90a4b0..d430a7b0cef2 100644
--- a/net-libs/nodejs/nodejs-9.2.0.ebuild
+++ b/net-libs/nodejs/nodejs-9.2.0.ebuild
@@ -18,13 +18,15 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
IUSE="cpu_flags_x86_sse2 debug doc icu +npm +snapshot +ssl systemtap test"
-RDEPEND="icu? ( >=dev-libs/icu-59:= )
- npm? ( ${PYTHON_DEPS} )
- >=net-libs/http-parser-2.7.0:=
+RDEPEND="
>=dev-libs/libuv-1.16.1:=
+ >=net-libs/http-parser-2.7.0:=
>=net-libs/nghttp2-1.25.0
- >=dev-libs/openssl-1.0.2g:0=[-bindist]
- sys-libs/zlib"
+ sys-libs/zlib
+ icu? ( >=dev-libs/icu-59:= )
+ npm? ( ${PYTHON_DEPS} )
+ ssl? ( >=dev-libs/openssl-1.0.2g:0=[-bindist] )
+"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
systemtap? ( dev-util/systemtap )
@@ -89,14 +91,14 @@ src_prepare() {
}
src_configure() {
- local myarch=""
- local myconf=( --shared-http-parser --shared-libuv --shared-nghttp2 --shared-openssl --shared-zlib )
- use npm || myconf+=( --without-npm )
+ local myconf=( --shared-http-parser --shared-libuv --shared-nghttp2 --shared-zlib )
+ use debug && myconf+=( --debug )
use icu && myconf+=( --with-intl=system-icu ) || myconf+=( --with-intl=none )
+ use npm || myconf+=( --without-npm )
use snapshot && myconf+=( --with-snapshot )
- use ssl || myconf+=( --without-ssl )
- use debug && myconf+=( --debug )
+ use ssl && myconf+=( --shared-openssl ) || myconf+=( --without-ssl )
+ local myarch=""
case ${ABI} in
amd64) myarch="x64";;
arm) myarch="arm";;