summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-11-20 14:21:46 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-11-20 14:24:47 -0600
commit9ce9b123961a4dc19932e4cc81908b624eeba282 (patch)
tree016a713f0221586662a8489745ff0699fcd29536 /net-libs/nodejs
parentnet-libs/nodejs: restore PaX support (diff)
downloadgentoo-9ce9b123961a4dc19932e4cc81908b624eeba282.tar.gz
gentoo-9ce9b123961a4dc19932e4cc81908b624eeba282.tar.bz2
gentoo-9ce9b123961a4dc19932e4cc81908b624eeba282.zip
net-libs/nodejs: add PaX support to 14.15.1
Bug: https://bugs.gentoo.org/735832 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/nodejs-14.15.1.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-libs/nodejs/nodejs-14.15.1.ebuild b/net-libs/nodejs/nodejs-14.15.1.ebuild
index fad4f233fa09..0f1006e67884 100644
--- a/net-libs/nodejs/nodejs-14.15.1.ebuild
+++ b/net-libs/nodejs/nodejs-14.15.1.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
PYTHON_REQ_USE="threads(+)"
-inherit bash-completion-r1 flag-o-matic python-any-r1 toolchain-funcs xdg-utils
+inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
DESCRIPTION="A JavaScript runtime built on Chrome's V8 JavaScript engine"
HOMEPAGE="https://nodejs.org/"
@@ -16,7 +16,7 @@ LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
SLOT="0/$(ver_cut 1)"
KEYWORDS="amd64 arm arm64 ~ppc64 x86 ~amd64-linux ~x64-macos"
-IUSE="cpu_flags_x86_sse2 debug doc +icu inspector +npm +snapshot +ssl system-icu +system-ssl systemtap test"
+IUSE="cpu_flags_x86_sse2 debug doc +icu inspector +npm pax_kernel +snapshot +ssl system-icu +system-ssl systemtap test"
REQUIRED_USE="inspector? ( icu ssl )
npm? ( ssl )
system-icu? ( icu )
@@ -35,7 +35,8 @@ RDEPEND=">=app-arch/brotli-1.0.9
BDEPEND="${PYTHON_DEPS}
sys-apps/coreutils
systemtap? ( dev-util/systemtap )
- test? ( net-misc/curl )"
+ test? ( net-misc/curl )
+ pax_kernel? ( sys-apps/elfix )"
DEPEND="${RDEPEND}"
PATCHES=(
@@ -85,6 +86,9 @@ src_prepare() {
BUILDTYPE=Debug
fi
+ # We need to disable mprotect on two files when it builds Bug 694100.
+ use pax_kernel && PATCHES+=( "${FILESDIR}"/${PN}-13.8.0-paxmarking.patch )
+
default
}
@@ -144,6 +148,8 @@ src_install() {
local LIBDIR="${ED}/usr/$(get_libdir)"
default
+ pax-mark -m "${ED}"/usr/bin/node
+
# set up a symlink structure that node-gyp expects..
dodir /usr/include/node/deps/{v8,uv}
dosym . /usr/include/node/src