summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-05-13 23:21:26 +0200
committerMarek Szuba <marecki@gentoo.org>2021-05-13 23:35:58 +0200
commitc1bc93122e06423e545ceee2377c4beaf8de970b (patch)
tree0a605b635603373de8ded9170cf902880f433e54 /net-libs/nodejs
parentsys-apps/gentoo-functions: Stabilize 0.14 ppc, #790038 (diff)
downloadgentoo-c1bc93122e06423e545ceee2377c4beaf8de970b.tar.gz
gentoo-c1bc93122e06423e545ceee2377c4beaf8de970b.tar.bz2
gentoo-c1bc93122e06423e545ceee2377c4beaf8de970b.zip
net-libs/nodejs: support python3_10
The version of jinja bundled with v8 (in all versions currently in the tree) still imports ABCs from collections rather than collections.abc, then again with that patched everything seems to be in order. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/files/nodejs-12.22.1-jinja_collections_abc.patch11
-rw-r--r--net-libs/nodejs/nodejs-12.22.1-r1.ebuild3
-rw-r--r--net-libs/nodejs/nodejs-14.16.1-r1.ebuild3
-rw-r--r--net-libs/nodejs/nodejs-16.1.0.ebuild3
-rw-r--r--net-libs/nodejs/nodejs-99999999.ebuild6
5 files changed, 22 insertions, 4 deletions
diff --git a/net-libs/nodejs/files/nodejs-12.22.1-jinja_collections_abc.patch b/net-libs/nodejs/files/nodejs-12.22.1-jinja_collections_abc.patch
new file mode 100644
index 000000000000..45be8cb07f8d
--- /dev/null
+++ b/net-libs/nodejs/files/nodejs-12.22.1-jinja_collections_abc.patch
@@ -0,0 +1,11 @@
+--- a/deps/v8/third_party/jinja2/tests.py
++++ b/deps/v8/third_party/jinja2/tests.py
+@@ -10,7 +10,7 @@
+ """
+ import operator
+ import re
+-from collections import Mapping
++from collections.abc import Mapping
+ from jinja2.runtime import Undefined
+ from jinja2._compat import text_type, string_types, integer_types
+ import decimal
diff --git a/net-libs/nodejs/nodejs-12.22.1-r1.ebuild b/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
index 84110ff87064..754e3973f544 100644
--- a/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-12.22.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
@@ -53,6 +53,7 @@ DEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-10.3.0-global-npm-config.patch
"${FILESDIR}"/${PN}-12.20.1-fix_ppc64_crashes.patch
+ "${FILESDIR}"/${PN}-12.22.1-jinja_collections_abc.patch
"${FILESDIR}"/${PN}-12.22.1-uvwasi_shared_libuv.patch
"${FILESDIR}"/${PN}-12.22.1-v8_icu69.patch
"${FILESDIR}"/${PN}-99999999-llhttp.patch
diff --git a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
index 82f78fb0068e..6f3e887f73d1 100644
--- a/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
+++ b/net-libs/nodejs/nodejs-14.16.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
@@ -48,6 +48,7 @@ DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${PN}-10.3.0-global-npm-config.patch
+ "${FILESDIR}"/${PN}-12.22.1-jinja_collections_abc.patch
"${FILESDIR}"/${PN}-12.22.1-uvwasi_shared_libuv.patch
"${FILESDIR}"/${PN}-14.15.0-fix_ppc64_crashes.patch
"${FILESDIR}"/${PN}-14.16.1-v8_icu69.patch
diff --git a/net-libs/nodejs/nodejs-16.1.0.ebuild b/net-libs/nodejs/nodejs-16.1.0.ebuild
index 2d9a2dbb00c8..e1f164dff75c 100644
--- a/net-libs/nodejs/nodejs-16.1.0.ebuild
+++ b/net-libs/nodejs/nodejs-16.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
@@ -47,6 +47,7 @@ BDEPEND="${PYTHON_DEPS}
DEPEND="${RDEPEND}"
PATCHES=(
+ "${FILESDIR}"/${PN}-12.22.1-jinja_collections_abc.patch
"${FILESDIR}"/${PN}-12.22.1-uvwasi_shared_libuv.patch
"${FILESDIR}"/${PN}-15.2.0-global-npm-config.patch
"${FILESDIR}"/${PN}-16.1.0-test-repl-history-navigation.patch
diff --git a/net-libs/nodejs/nodejs-99999999.ebuild b/net-libs/nodejs/nodejs-99999999.ebuild
index 2b81f6a39ed8..2d45db3952a5 100644
--- a/net-libs/nodejs/nodejs-99999999.ebuild
+++ b/net-libs/nodejs/nodejs-99999999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="threads(+)"
inherit bash-completion-r1 flag-o-matic pax-utils python-any-r1 toolchain-funcs xdg-utils
@@ -46,6 +46,10 @@ BDEPEND="${PYTHON_DEPS}
pax_kernel? ( sys-apps/elfix )"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-12.22.1-jinja_collections_abc.patch # still needed as of 2021-05-13
+)
+
pkg_pretend() {
(use x86 && ! use cpu_flags_x86_sse2) && \
die "Your CPU doesn't support the required SSE2 instruction."