summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-02-26 00:19:48 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-02-26 00:29:42 +0100
commit15f5b932e915280dd97a24f266947446d7088af0 (patch)
tree00317ba7743c42767ef988915482df087d9eb1f1 /net-libs/ntirpc/ntirpc-1.6.1.ebuild
parentsys-kernel/vanilla-sources: Linux patcn 4.4.118, 4.9.84, 4.14.22, 4.15.6 (diff)
downloadgentoo-15f5b932e915280dd97a24f266947446d7088af0.tar.gz
gentoo-15f5b932e915280dd97a24f266947446d7088af0.tar.bz2
gentoo-15f5b932e915280dd97a24f266947446d7088af0.zip
net-libs/ntirpc: Bump to v1.6.1
Ebuild changes: =============== - New upstream. - Added missing dependency on net-libs/libnsl. [Bug 647040] - Fixed "rdma" USE flag usage (USE_RPC_RDMA had a typo). Closes: https://bugs.gentoo.org/647040 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-libs/ntirpc/ntirpc-1.6.1.ebuild')
-rw-r--r--net-libs/ntirpc/ntirpc-1.6.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/ntirpc/ntirpc-1.6.1.ebuild b/net-libs/ntirpc/ntirpc-1.6.1.ebuild
new file mode 100644
index 000000000000..c78565d83635
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-1.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-multilib
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="app-crypt/mit-krb5
+ net-libs/libnsl
+ rdma? ( sys-fabric/librdmacm )"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake-utils_src_configure
+}