summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-06-12 14:39:29 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-06-12 14:40:09 +0200
commit806afefc70ff37f061aaeb925a9814c2d10269c6 (patch)
tree65a104dc18d7c9c03569b9595abfab65a7e3ebae /net-libs/ntirpc/ntirpc-1.7.4.ebuild
parentnet-misc/smb4k: Drop 2.9.90 (diff)
downloadgentoo-806afefc70ff37f061aaeb925a9814c2d10269c6.tar.gz
gentoo-806afefc70ff37f061aaeb925a9814c2d10269c6.tar.bz2
gentoo-806afefc70ff37f061aaeb925a9814c2d10269c6.zip
net-libs/ntirpc: Bump to version 1.7.4
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs/ntirpc/ntirpc-1.7.4.ebuild')
-rw-r--r--net-libs/ntirpc/ntirpc-1.7.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/ntirpc/ntirpc-1.7.4.ebuild b/net-libs/ntirpc/ntirpc-1.7.4.ebuild
new file mode 100644
index 000000000000..a6136e935816
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-1.7.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="app-crypt/mit-krb5
+ net-libs/libnsl
+ rdma? ( sys-fabric/librdmacm )"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake-utils_src_configure
+}