summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-12-28 11:48:40 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-12-28 11:49:21 +0100
commite8237c52407a2e50c5e2d67d1acea4dd278f65d1 (patch)
tree9240335f316722f77e99ed818e4518f572ad01f0 /net-libs/ntirpc/ntirpc-3.4.ebuild
parentdev-ruby/racc: avoid dep on rdoc (diff)
downloadgentoo-e8237c52407a2e50c5e2d67d1acea4dd278f65d1.tar.gz
gentoo-e8237c52407a2e50c5e2d67d1acea4dd278f65d1.tar.bz2
gentoo-e8237c52407a2e50c5e2d67d1acea4dd278f65d1.zip
net-libs/ntirpc: Bump to version 3.4
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'net-libs/ntirpc/ntirpc-3.4.ebuild')
-rw-r--r--net-libs/ntirpc/ntirpc-3.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/ntirpc/ntirpc-3.4.ebuild b/net-libs/ntirpc/ntirpc-3.4.ebuild
new file mode 100644
index 000000000000..6e63e824706b
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-3.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="https://github.com/nfs-ganesha/ntirpc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="
+ dev-libs/userspace-rcu
+ rdma? ( sys-fabric/librdmacm )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake_src_configure
+}