summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/ortp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/ortp')
-rw-r--r--net-libs/ortp/Manifest3
-rw-r--r--net-libs/ortp/metadata.xml10
-rw-r--r--net-libs/ortp/ortp-0.20.0.ebuild77
-rw-r--r--net-libs/ortp/ortp-0.22.0.ebuild82
-rw-r--r--net-libs/ortp/ortp-0.23.0.ebuild75
5 files changed, 247 insertions, 0 deletions
diff --git a/net-libs/ortp/Manifest b/net-libs/ortp/Manifest
new file mode 100644
index 000000000000..ae06cb5381ea
--- /dev/null
+++ b/net-libs/ortp/Manifest
@@ -0,0 +1,3 @@
+DIST ortp-0.20.0.tar.gz 515505 SHA256 f2a8263f8242756e2ce092c710ac068cd4b21051fc70c1937b275193a2bfb3d3 SHA512 a4d666be6b6825eeb28204001d5d1263c80ef3c07931586e753d3efa8c72d76e993335c4eeaa558209b5d10d5e991ba0c88e2f5c9a35aff46b36d6e76f92b706 WHIRLPOOL cc1a9473580748a76d26bde42f074bd9bbb1bd066a7b514b0016dd75d2d5b57ff29eba18e10139457acc406593bb566fdc8c256a4241a77718d965419ecd8b50
+DIST ortp-0.22.0.tar.gz 538024 SHA256 6e37e29b3c3559bac1f2ae0c977f6ceb4d4ce8dc713b691dea8bae57bda92d0b SHA512 0453f19fd3388c3dcd12f118dbfc1a460fae77e4f9e82b1b71f4014e3bbba4d480f811d07bc781dced1fb2685901eaea364c8276c0d083f5e8d6b7074f7c4fba WHIRLPOOL 00f31d4de912dcf29778e68f5c88001eb845653303048d5c29a3c1488b1fae42399292df91596cabe1a223a4171a409af452cee97a3f075230918b068212e99c
+DIST ortp-0.23.0.tar.gz 540135 SHA256 91a5ada15f62ce5f08beceef4d0adb65469211e2f208bd96e493a8df9f84fcdb SHA512 70560168f1b138ad825e4e836e7ee218bd24b92a2d76666ba2794a4b31cadbdd8fdd40fee78d612187cde6a827005cbd836cdfc13a70947374356fb84a853ea4 WHIRLPOOL cb9dc4c925ed92816d58dc66bab9f179d6a99abe64a218710cd92763422cb8b5f81ce4bdc5ad935798e792d7a5f3ab74e9b8cbdfc9bbde7781ce92d7b90ef507
diff --git a/net-libs/ortp/metadata.xml b/net-libs/ortp/metadata.xml
new file mode 100644
index 000000000000..caea1a2964c9
--- /dev/null
+++ b/net-libs/ortp/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>chainsaw@gentoo.org</email></maintainer>
+ <use>
+ <flag name='ntp-timestamp'>Turn on NTP timestamping on received packet</flag>
+ <flag name='srtp'>Add support for Secure RTP</flag>
+ <flag name='zrtp'>Add support for ZRTP key negotiation</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-libs/ortp/ortp-0.20.0.ebuild b/net-libs/ortp/ortp-0.20.0.ebuild
new file mode 100644
index 000000000000..075791ee66a3
--- /dev/null
+++ b/net-libs/ortp/ortp-0.20.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Open Real-time Transport Protocol (RTP, RFC3550) stack"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="mirror://nongnu/linphone/${PN}/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug doc examples ipv6 minimal srtp ssl" # zrtp"
+
+# Note:
+# This package supposedly requires libzrtpcpp-2.0.0
+# but it is incompatible with its API...
+
+RDEPEND="srtp? ( net-libs/libsrtp )
+ ssl? ( dev-libs/openssl )"
+# zrtp? ( >=net-libs/libzrtpcpp-2.0.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+#REQUIRED_USE="zrtp? ( srtp )"
+
+src_prepare() {
+ # ${P} is added after ${docdir}
+ if use doc; then
+ sed -i -e 's/$(docdir)\/$(PACKAGE)-$(VERSION)/$(docdir)/' Makefile.in \
+ || die "patching Makefile.in failed"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ # memcheck is for HP-UX only
+ --disable-memcheck
+ # mode64bit adds +DA2.0W +DS2.0 CFLAGS wich are needed for HP-UX
+ --disable-mode64bit
+ # strict adds -Werror, don't want it
+ --disable-strict
+ # they seriously failed to understand AC_ARG_ENABLE...
+ --disable-tests_enabled
+ --enable-fast-install
+ --enable-libtool-lock
+
+ $(use_enable debug)
+ $(use_enable ipv6)
+ $(use_enable minimal perf)
+ $(use_enable ssl ssl-hmac)
+# $(use_enable zrtp)
+ --disable-zrtp
+
+ "--with-srtp=$(usex srtp "${EPREFIX}"/usr none)"
+ $(use doc || echo ac_cv_path_DOXYGEN=false)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF} \
+ install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ prune_libtool_files
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/tests/*.c
+ fi
+}
diff --git a/net-libs/ortp/ortp-0.22.0.ebuild b/net-libs/ortp/ortp-0.22.0.ebuild
new file mode 100644
index 000000000000..855362c6e3db
--- /dev/null
+++ b/net-libs/ortp/ortp-0.22.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Open Real-time Transport Protocol (RTP, RFC3550) stack"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="mirror://nongnu/linphone/${PN}/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/9"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug doc examples ipv6 minimal ntp-timestamp ssl" # srtp zrtp"
+
+# Note:
+# This package supposedly requires libzrtpcpp-2.0.0
+# but it is incompatible with its API...
+#
+# This package supposedly requires libsrtp
+# but it is incompatible with its API...
+
+RDEPEND="ssl? ( dev-libs/openssl )"
+# srtp? ( net-libs/libsrtp )
+# zrtp? ( >=net-libs/libzrtpcpp-2.0.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+#REQUIRED_USE="zrtp? ( srtp )"
+
+src_prepare() {
+ # ${P} is added after ${docdir}
+ if use doc; then
+ sed -i -e 's/$(docdir)\/$(PACKAGE)-$(VERSION)/$(docdir)/' Makefile.in \
+ || die "patching Makefile.in failed"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ # memcheck is for HP-UX only
+ --disable-memcheck
+ # mode64bit adds +DA2.0W +DS2.0 CFLAGS wich are needed for HP-UX
+ --disable-mode64bit
+ # strict adds -Werror, don't want it
+ --disable-strict
+ # they seriously failed to understand AC_ARG_ENABLE...
+ --disable-tests_enabled
+ --enable-fast-install
+ --enable-libtool-lock
+
+ $(use_enable debug)
+ $(use_enable ipv6)
+ $(use_enable minimal perf)
+ $(use_enable ntp-timestamp)
+ $(use_enable ssl ssl-hmac)
+# $(use_enable zrtp)
+ --disable-zrtp
+
+# "--with-srtp=$(usex srtp "${EPREFIX}"/usr none)"
+ --with-srtp=none
+ $(use doc || echo ac_cv_path_DOXYGEN=false)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF} \
+ install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ prune_libtool_files
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/tests/*.c
+ fi
+}
diff --git a/net-libs/ortp/ortp-0.23.0.ebuild b/net-libs/ortp/ortp-0.23.0.ebuild
new file mode 100644
index 000000000000..18a80ad47548
--- /dev/null
+++ b/net-libs/ortp/ortp-0.23.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Open Real-time Transport Protocol (RTP, RFC3550) stack"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="mirror://nongnu/linphone/${PN}/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/9"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="debug doc examples ipv6 minimal ntp-timestamp ssl srtp zrtp"
+
+RDEPEND="ssl? ( dev-libs/openssl:0= )
+ srtp? ( net-libs/libsrtp:0= )
+ zrtp? ( >=net-libs/libzrtpcpp-4.0.0:0= )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+REQUIRED_USE="zrtp? ( srtp )"
+
+src_prepare() {
+ # ${P} is added after ${docdir}
+ if use doc; then
+ sed -i -e 's/$(docdir)\/$(PACKAGE)-$(VERSION)/$(docdir)/' Makefile.in \
+ || die "patching Makefile.in failed"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ # memcheck is for HP-UX only
+ --disable-memcheck
+ # mode64bit adds +DA2.0W +DS2.0 CFLAGS wich are needed for HP-UX
+ --disable-mode64bit
+ # strict adds -Werror, do not want it
+ --disable-strict
+ # they seriously failed to understand AC_ARG_ENABLE...
+ --disable-tests_enabled
+ --enable-fast-install
+ --enable-libtool-lock
+ # this is fine as long as we do not link to polarssl
+ --enable-broken-srtp
+
+ $(use_enable debug)
+ $(use_enable ipv6)
+ $(use_enable minimal perf)
+ $(use_enable ntp-timestamp)
+ $(use_enable ssl ssl-hmac)
+ $(use_enable zrtp)
+
+ --with-srtp=$(usex srtp "${EPREFIX}"/usr none)
+ $(use doc || echo ac_cv_path_DOXYGEN=false)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdocdir="${EPREFIX}"/usr/share/doc/${PF} \
+ install
+ dodoc AUTHORS ChangeLog NEWS README TODO
+
+ prune_libtool_files
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/tests/*.c
+ fi
+}